Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I'm running Apache 1.3 and having some issues getting the test page to display. The server is configured with the following options (among others) in httpd.conf: Code: 'ServerType standalone' ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    2

    Apache test page does not load


    Hi, I'm running Apache 1.3 and having some issues getting the test page to display.

    The server is configured with the following options (among others) in httpd.conf:
    Code:
      'ServerType standalone'
      'Port 8080'
      'ServerName localhost'   (I've also tried 'ServerName 127.0.0.1')
      'DocumentRoot /var/www'
      '<Directory /var/www/>'
      '    Options Indexes Includes FollowSymLinks MultiViews'
      '    AllowOverride None'
      '    Order allow,deny'
      '    Allow from all'
      '</Directory>'
      '<IfModule mod_dir.c>'
      '    DirectoryIndex index.html index.htm index.shtml index.cgi index.php'
      '</IfModule>'
    The file '/var/www/index.html' exists with the attribs '-rw-r--r--'.

    The server's been started with:
    'apachectl start'
    and reports:
    '/usr/sbin/apachectl start: httpd started'.

    I've verified that it's listening with:
    'netstat -tap | grep LISTEN'
    which returns:
    'tcp 0 0 *:webcache *:* LISTEN 3078/apache'

    When I try to load the page by pointing a webbrowser on the same machine to 'http://localhost:8080/' or 'http://127.0.0.1:8080/' the browser just sits there 'Connecting to localhost...' but never displays the test page. (I've configured the server to various ports with no change.)

    Does anyone what's not set up properly?

    Thanks

  2. #2
    Linux Engineer jledhead's Avatar
    Join Date
    Oct 2004
    Location
    North Carolina
    Posts
    1,077
    have you checked your error log to see what its saying?

    also, if this is a new install, why not try a new version of apache instead of 1.3?

  3. #3
    Just Joined!
    Join Date
    Apr 2005
    Posts
    88

    Apache Error

    Greetings,

    By default the apache service runs on Port 80 and you are trying to run on port 8080, Can u check if u made an entry for the port 8080 in the httpd.conf or not. Otherwsie you can try to load the page on the following URL http://127.0.0.1/

    Regards

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    May 2005
    Posts
    2

    Problem Solved

    Thanks for the ideas. I ended up resolving the issue. It turned out it was a system configuration and not Apahce problem. A quick 'ifconfig lo 127.0.0.1` and a 'route add 127.0.0.1 eth0' fixed it all!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •