Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 30
I'm not on linux right now so the IPs def won't work, even though i know they dont anyway :P Anyway... just thought I'd let you know.......
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Apr 2005
    Posts
    54

    I'm not on linux right now


    I'm not on linux right now so the IPs def won't work, even though i know they dont anyway :P
    Anyway... just thought I'd let you know....

  2. #12
    Just Joined!
    Join Date
    Apr 2005
    Posts
    54
    Greetings,

    The port 80 on the Public IP Address is opened I just checked that by doing a telnet on port 80. Now, can you confirm to me if you had made a entry in the /etc/hosts file for the Private IP Address i.e 192.168.2.2 with a corresponding hostname and specified the same hostname in the httpd.conf file for the Apache Web Server. It shud work then.

    Regards
    Can somebody explain that to me? Step by step?
    Thanks

  3. #13
    Just Joined!
    Join Date
    Apr 2005
    Posts
    54

    Sorry

    Sorry about the four posts in a row just I have more information.
    I finally understood what KidCLoudWala said and this is what it says in the hosts file...
    127.0.0.1 localhost
    What do I need to write in that file and httpd.conf?

  4. $spacer_open
    $spacer_close
  5. #14
    Just Joined!
    Join Date
    Apr 2005
    Posts
    88
    Greetings,

    In the /etc/hosts file make an entry 192.168.2.2 <hostname of the computer> and in the httpd.conf specify the hostname against the ServerName.

    Regards

  6. #15
    Just Joined!
    Join Date
    Apr 2005
    Posts
    54

    SORRY

    Sorry this is a bit of a bad question because I knew where it was when I manually installed apache before but now that ive installed it whilst installing linux, I'm not sure where it has put it. Where does mandrake linux 10.1 install the httpd.conf file to?

  7. #16
    Just Joined!
    Join Date
    Apr 2005
    Posts
    88
    Greetings,

    Try to locate the file using the command locate httpd.conf and make ane entry to it.

    Regards

  8. #17
    Just Joined!
    Join Date
    Apr 2005
    Posts
    54

    I tried

    I tried this but it didn't work, it works when I try and go to it but not when others do. Have I done this correctly:

    In the /etc/hosts file:
    127.0.0.1 localhost
    192.168.2.2 sftrhost
    And in the httpd.conf file:
    ### Main Configuration Section
    ### You really shouldn't change these settings unless you're a guru
    ###
    ServerType standalone
    ServerRoot /etc/httpd
    #ServerName sftrhost
    #LockFile /etc/httpd/httpd.lock
    PidFile /var/run/httpd.pid
    ScoreBoardFile /etc/httpd/httpd.scoreboard
    ErrorLog logs/error_log
    LogLevel warn
    ResourceConfig /dev/null
    AccessConfig /dev/null
    DocumentRoot /var/www/html
    ...
    Whats wrong?

  9. #18
    Just Joined!
    Join Date
    Apr 2005
    Posts
    88
    Greetings,

    Uncomment this entry: #ServerName sftrhost

    Regards

  10. #19
    Just Joined!
    Join Date
    Apr 2005
    Posts
    54

    Hmmm...

    I did that... should it work now? I've tried giving people my IP address (82.3.32.73) but still it doesn't work. Am I giving them the correct one?
    They say it just says the URL does not exist... though it has connected to my computer. Am I putting my files in the correct folder? /var/www/html/ ?
    Thanks

    Not on linux at the moment... if you need me to be, just post and ask

  11. #20
    Linux User
    Join Date
    Feb 2005
    Posts
    290
    did you setup port mapping or something from your router to your linux box?

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •