Find the answer to your Linux question:
Results 1 to 2 of 2
I am trying to add a Linux (SUSE 9.2) PC (Host name Green) to a TCP/IP network using SAMBA (3). I have attempted to configure Samba to get my Linux ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Location
    Weymouth UK
    Posts
    2

    Can't connect to Linux Share on XP PC


    I am trying to add a Linux (SUSE 9.2) PC (Host name Green) to a TCP/IP network using SAMBA (3).

    I have attempted to configure Samba to get my Linux Box join the workgroup Spectrum which is the workgroup containing my XP PRO PC (Host name Blue).

    On the XP machine under network tasks>>View workgroup computers I see just computer “Green – encrypt Samber Server (Green)” when I double click on the “Green – encrypt Samber Server (Green)” icon I get, after a delay, the following error message:

    \\Green is not accessible. You might not have permission to use this network resource. Contact the administrator of the server to find out if you have access permissions.

    The network path was not found.

    The network card in the Linux PC has an IP of 192.168.0.5
    My router (Netgear DG834G with latest firmware) acts as a DHCP for the XP PC allocating it 192.168.0.2 I can ping each PC from the other.

    I have set up an admin account (Anybody) on the XP PC with a password “XXXXX”.
    On the Linux PC I have created a user account of the same name (Anybody) and the same password “XXXXX”.
    I also assigned the user Anybody “XXXXX” as a smb password using:

    smbpasswd –a Anybody

    I created a resource (share) directory

    /export

    ‘owned’ by user ‘netfiles’ of group ‘users’
    I gave ‘netfiles’ the same user and smb password (different from that of user ‘Anybody’).

    I used
    Chmod 777 /export

    To give full access rights to the directory.

    My smb.conf file is as follows:

    [global]
    workgroup = SPECTRUM
    Netbios name = GREEN
    encrypt passwords = yes
    Server string = Green – encrypt Samber Server
    Security = SHARE

    [netfss]
    comment = Green – new Samba test area
    path = /export
    force user = netfiles
    force group = users
    read only = no
    guest ok = yes

    (based on ideas from articles and forum responses – I understand that it should give any samba user access to file /export with the use of the netfiles samba/user password)

    Running testparm reveals no errors in smb.conf although it ignores the 2nd and 3rd lines in [global] I assume because they are defaults.

    I have configured the system to run samba on boot-up.
    I used YAST to configure the firewall to allow all file and web services and to be on the safe side TCP: 139 445 UDP 137 138.
    I have disabled my Windows XP Firewall (I believe that the hardware firewall in my DG834G router will protect me from Internet nasties while leaving my XP/Linux traffic unaffected – I might be wrong about this).


    I expect to see a network folder “netfss” under computer Samba Server (Green) under workgroup Spectrum. Presumably folder ‘export’ will exist under ‘netfss’ accessible with netfiles password.

    My session was as follows:

    Logged into Linux on Linux Box (Green)
    user Anyone
    Password XXXXX

    Logged into windows on XP Box (Blue)
    User Anyone
    Password XXXXX

    On XP Box went to Start>My Network Places>View workgroup computers this put me into the Spectrum workgroup which had two computer icons:
    Blue
    Green – encrypt Samber Server (Green)

    Double clicking on Green gave after a delay the \\ Green not accessible…… error

    On the Linux Box I found a Network Browsing icon on the desktop which put me through to a services folder containing two items

    “All SLP Services” and “Windows Network”.

    I clicked on “Windows Network” which put me through to

    smb:/

    an empty folder
    after a short period the message

    “Error while connecting to server responsible for smb:/”

    appeared.

    The log files log.smbd said nothing of note but log.nmbd contained the following:

    [2005/05/12 20:17:03, 0] nmbd/nmbd.c:main(664)
    Netbios nameserver version 3.0.7-5.1-SUSE started.
    Copyright Andrew Tridgell and the Samba Team 1994-2004
    [2005/05/12 20:17:04, 0] nmbd/nmbd_subnetdb.c:create_subnets(217)
    create_subnets: No local interfaces !
    [2005/05/12 20:17:04, 0] nmbd/nmbd_subnetdb.c:create_subnets(218)
    create_subnets: Waiting for an interface to appear ...
    [2005/05/12 20:43:12, 0] nmbd/nmbd_become_lmb.c:become_local_master_stage2(396)
    *****

    Samba name server GREEN is now a local master browser for workgroup SPECTRUM on subnet 192.168.0.5

    *****


    Is there a name server issue? Or something more related to encryption?
    Any suggestions for a way forward?

  2. #2
    Just Joined!
    Join Date
    Apr 2005
    Location
    Yorkshire
    Posts
    19
    Hi,

    I'm already running a similar query on

    "Peer to Peer" posted by memeplex (me!)

    care to join in?

    or compare notes?

    memeplex

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •