Find the answer to your Linux question:
Results 1 to 5 of 5
hi, I need to connect a linux (FC3) machine to a windows workgroup. In the following description CEYAH is a linux machine and MACHINA is a windows machine. I downloaded ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    14

    Need help with samba


    hi,

    I need to connect a linux (FC3) machine to a windows workgroup.

    In the following description CEYAH is a linux machine and MACHINA is a windows machine.

    I downloaded and installed the latest (3.0.14a) samba release and followed all the tutorials in the samba.org site but still I can't make the Windows machines in the workgroup to access services on the linux machine.

    I do get network connectivity between the machines and I can see the linux machine in "My Network Places" but still when I try to view its services using "net view \\CEYAH" I get "The network path was not found".

    I can view services on the Windows machines from the linux machine using "smbclient -L \\MACHINA".

    Any ideas about what is wrong and what can I do to make it work?

  2. #2
    Just Joined!
    Join Date
    Aug 2003
    Posts
    19
    If you have encrypt passwords set to off on the samba box, you will have to make a change to the windows registry.

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\lanmanworkstation\parameters

    Oncey ou have navigated to there, find the "enableplaintextpasswords" and double click it. Change the value from 0 to 1. Then reboot the system.

  3. #3
    Just Joined!
    Join Date
    May 2005
    Posts
    14
    Quote Originally Posted by CompDude
    If you have encrypt passwords set to off on the samba box, you will have to make a change to the windows registry.

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\lanmanworkstation\parameters

    Oncey ou have navigated to there, find the "enableplaintextpasswords" and double click it. Change the value from 0 to 1. Then reboot the system.
    That's not it - the enableplaintextpasswords value was already set to 1
    although I changed it in services->local security policy.

  4. #4
    Just Joined!
    Join Date
    May 2005
    Posts
    14

    solved

    Problem solved - was a firewall issue : both nmbd and smbd listening ports (137,138,139,445) were blocked by the linux machine firewall.

  5. #5
    Linux Newbie
    Join Date
    Apr 2005
    Posts
    113

    Re: solved

    Quote Originally Posted by sambatyon
    Problem solved - was a firewall issue : both nmbd and smbd listening ports (137,138,139,445) were blocked by the linux machine firewall.
    That firewall issue messed me up for awhile at first too. Congrats on finding it yourself.
    You dont need a pocket protector or thick glasses to be a geek.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •