Find the answer to your Linux question:
Results 1 to 3 of 3
Ok, first off, I just installed Linux on this computer a week or two ago. I just got to starting up the server. I am running Fedora Core 3 with ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2005
    Posts
    3

    You don't have permission to access / on this server. - SOLVED


    Ok, first off, I just installed Linux on this computer a week or two ago. I just got to starting up the server. I am running Fedora Core 3 with the GNOME interface. I had some trouble setting up the httpd.conf, but I used the httpd.conf.bk file, (at least I think the last extension was .bk) assuming the bk meant backup, and changed the name from httpd.conf.bk to http.conf. Then, it worked. At least, a little. When I typed in my IP address, I got the welcome message that said I had the server running, I needed to add content to /var/www/http for the message to go away. I added a simple index.html file to that directory (that says hello in red type), then typed in my IP address again. I still got the welcome message, telling me that I needed to add content to /var/www/html. I made sure that index.html was in that directory, and it was. I edited welcome.conf to not display. Then, when I typed in my IP address, I got this:

    Forbidden

    You don't have permission to access / on this server.
    Apache/2.0.52 (Fedora) Server at 65.29.3.203 Port 80

    Then I tried to access index.html directly, as myip/index.html and I got

    Forbidden

    You don't have permission to access /index.html on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/2.0.52 (Fedora) Server at 65.29.3.203 Port 80

    I checked the CHMOD of index.html and the directory:
    the "html" directory was chmoded as 755, index.html was chmodded as 711. I tried changing the chmod of index.html to 755, no good. I changed the file owner and group to apache, still no go. Now, here's the strange part: when I made a sub-directory of the folder "html", called tester, I got no 403 forbidden error, just an empty directory listing as expected. The folder tester was chmoded exactly the same as the html folder, with the file owner as root. I copied index.html and moved it to the folder "tester"'s directory. It had the same file owner and chmod, 755 and apache, but it showed up when i typed in my ip address/tester. Heres a really odd thing: I can access files that are not named index.html. I copied index.html and renamed it as index2.html, then I was able to access it. Any ideas of what is wrong? I hope I was specific enough.

    My IP address is 65.29.3.203, you can see the directory forbidden error if you type in my IP address.
    You can see the index.html file that works if you type in 65.29.3.203 or 65.29.3.203/index2.html
    You can see my httpd.conf file if you type in 65.29.3.203/httpd.txt

  2. #2
    Just Joined!
    Join Date
    Jun 2005
    Posts
    3

    Solved

    I read this and it solved my problem, in case anyone has the same problem:

    http://fedora.redhat.com/docs/selinu...ple-setup.html

  3. #3
    Just Joined!
    Join Date
    Jul 2007
    Posts
    1
    Just Googled my problem and found this thread. Most of it was over my head, but I created a new folder, put my "forbidden" file there, and it fixed the problem.
    Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •