Find the answer to your Linux question:
Results 1 to 8 of 8
Ok Ive been doing some reasearch around Samba and smbfs. But I'm still having issues mounting a smbfs network folder on a fedora server to a fedora client. The server ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2005
    Posts
    12

    Linux Nubie - need a little samba direction


    Ok Ive been doing some reasearch around Samba and smbfs. But I'm still having issues mounting a smbfs network folder on a fedora server to a fedora client. The server is running samba because most its clients are using windows. But I need a linux client.

    Do I need samba intalled on my client?
    I just built this CPU with a clean install of Fedora. Are there any other preliminry actions i need to take?


    Help Please.....

  2. #2
    Just Joined!
    Join Date
    Mar 2005
    Location
    South Africa
    Posts
    88
    Have you tried
    Code:
    smbmount //<share location> /mountdir
    on the client.
    I'm not too sure if you need to have samba installed on the client, I would assume if it has smbmount then it should be fine.

  3. #3
    Just Joined!
    Join Date
    Jun 2005
    Posts
    12
    Yea ive tried that and i get "bash: smbmount: command not found"

    This is a fresh install of Fedora Core 2, I'm not sure if I'm missing some key pieces to build this OS.

    I appreciate the help, let me know if you have any more suggestions.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    Have you tried doing this as root
    Code:
    su
    &#91;rootpass&#93;
    smbmount //<share location> /mountdir
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  6. #5
    Just Joined!
    Join Date
    Jun 2005
    Posts
    12
    Yes, Ive allso tried:
    Code:
    &#93;#  mount -t smbfs 155.34.129.17&#58;/ncpfs/div3vol2 /mnt/div3vol2
    mount&#58; wrong fs type, bad option, bad superblock on 155.34.129.17&#58;/ncpfs/div3vol2,
           or too many mounted file systems
    all with root..

  7. #6
    Linux Engineer Giro's Avatar
    Join Date
    Jul 2003
    Location
    England
    Posts
    1,219
    Try this changing MY_WORKGROUP to your workgroup,
    Code:
    modprobe smbfs; mount -t smbfs -o workgroup=MY_WORKGROUP //155.34.129.17/ncpfs/div3vol2 /mnt/div3vol2

  8. #7
    Just Joined!
    Join Date
    Apr 2005
    Posts
    62
    you dont actually need samba server running in your linux samba client just to access the shared resources of your samba server box. Other way to access those samba shared or windows shared from you linux box is to use you file browser (nautilus for gnome, konqueror for kde) then at the location, just type smb://<ip-of-the-box-with-shared-resources>
    if promted a username and password, in linux server, try to enter the smbpasswd account, in windows, the especially 2k, or xp, those username that has access on the shared folder.

    also, if you want to access your linux box from a linux client, and on that box, you've installed ssh server, you can also use the file browser mentioned and just type sftp://<ip-of-that-box> and the user and password that you have on that box (system account) and you can access the home of that account you entered

  9. #8
    Just Joined!
    Join Date
    May 2006
    Posts
    1
    For the benefit of the next person who has this problem and finds this page in a search engine:

    I had the same problem and it was becaues a key Debian/*Ubuntu package wasn't installed.

    % apt-get install smbfs

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •