Find the answer to your Linux question:
Results 1 to 2 of 2

Thread: vsftpd ssl/tls

Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005

    vsftpd ssl/tls

    I'm trying to setup vsftpd to use ssl/tls. I verified that vsftpd was working beforehand. I then made my changes to vsftpd.conf.

    The directives I added/edited were as follows:


    I also set my rsa cert file.

    The daemon starts fine, but I can not connect to it. I tried Konqueror and FileZilla.

    In Konqueror, I just type in, it brings up the login box, I attempt to login, and it tells me that the login requires encryption. So it obviouslly isn't trying to encrypt the login. Is this because of the URL? I tried using s, and it said it had problems talking to SSH.

    In FileZilla, I added a site with information such as it using TLS, the domain name, etc. It's feedback thing said that it logged in, and was requesting a directory listing, but it just hangs there.

    At this point, I'm not sure if it's a client or a server problem. I'm lost.

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    You should specify the port number in your browser. From /etc/services:

    ftps-data       989/tcp                         # ftp protocol, data, over TLS/SSL
    ftps-data       989/udp
    ftps            990/tcp                         # ftp protocol, control, over TLS/SSL
    ftps            990/udp
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts