Find the answer to your Linux question:
Results 1 to 2 of 2
hi... i can't resolve names on the network , and just i can use ip adress... so i make linux as wins server by remove ( at the begin of ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    51

    i can't resolve names on the network


    hi...
    i can't resolve names on the network , and just i can use ip adress...
    so i make linux as wins server by remove ( at the begin of "wins support = yes" in smb.conf
    but without result.... then i use the HOSTS file for name resolution in both linux and windows and evry thing doing well but thet not good solution because i have more than 20 machines...
    is there any other good solution

    # This is the main Samba configuration file.
    [global]

    workgroup = workgroup
    netbios name = khaled
    server string = samba
    hosts allow = 192.168.0.
    printcap name = /etc/printcap
    load printers = yes
    cups options = raw
    ; guest account = pcguest
    log file = /var/log/samba/%m.log
    max log size = 50

    ; name resolve order = wins lmhosts bcast

    ; wins support = yes

    ; wins server = 192.168.0.100

    ; wins proxy = yes

    dns proxy = no

    #============================ Share Definitions ==============================
    idmap uid = 16777216-33554431
    idmap gid = 16777216-33554431
    template shell = /bin/false
    password server = None
    security = SHARE
    encrypt passwords = no
    winbind use default domain = no

  2. #2
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790

    Re: i can't resolve names on the network

    Quote Originally Posted by khh80
    then i use the HOSTS file for name resolution in both linux and windows and evry thing doing well but thet not good solution because i have more than 20 machines...
    is there any other good solution
    Are these 20 machines getting their IP by DHCP or static addresses? If it's static, it's a bit of a pain, but the HOSTS file will work, if it's DHCP, it wont necesarily work. Either way, you could try setting up bind, that should be able to do that for you. (iirc)
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •