Find the answer to your Linux question:
Results 1 to 8 of 8
I have just recovered from a serious user screw up that caused my software RAID array to foul up. Anway, I had to rebuild the array and reinstall Fedora, so ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2005
    Posts
    47

    Samba won't show any files


    I have just recovered from a serious user screw up that caused my software RAID array to foul up. Anway, I had to rebuild the array and reinstall Fedora, so I went ahead and upgarded from FC 3 to FC 4. I then copied all my old config files and CAD files back over to the array, but now I have a really weird problem. Samba appears to be working ok and it's very quick to respond to queries. My only problem is that it does not show any files in the shared directories. This setup was working perfectly under FC3 but it does not appear to work correctly on FC4. It's almost like I don't have permission to see any of the files even though I know I have the permissions set up correctly. I also have disabled SELinux and the firewall to rule those out, but it still continues with this behavior. Here is my smb.conf file:

    Code:
    # Samba config file created using SWAT
    # from 127.0.0.1 (127.0.0.1)
    # Date: 2005/07/08 15:24:42
    
    # Global parameters
    [global]
    	workgroup = WORKGROUP
    	realm = REALM.COM
    	server string = Dozer engineering file server
    	security = ADS
    	obey pam restrictions = Yes
    	password server = xxx.xxx.xxx.xxx
    	log file = /var/log/samba/%m.log
    	unix extensions = No
    	socket options = TCP_NODELAY SO_RCVBUF=16384 SO_SNDBUF=16384 IPTOS_LOWDELAY SO_KEEPALIVE
    	preferred master = No
    	local master = No
    	domain master = No
    	dns proxy = No
    	wins server = xxx.xxx.xxx.xxx
    	ldap ssl = no
    	idmap uid = 10000-20000
    	idmap gid = 10000-20000
    	template primary group = users
    	template homedir = /home/shares/bu_onen1/bu/users8/%u
    	template shell = /bin/bash
    	winbind separator = +
    	winbind cache time = 900
    	winbind use default domain = Yes
    	hosts allow = xxx.xxx.xxx.
    
    	hide special files = Yes
    	follow symlinks = No
    	keepalive = 900
    	deadtime = 0
    
    [homes]
    	comment = Home directory for %U
    	valid users = %S, %D+%S
    	read only = No
    	browseable = No
    
    [public]
    	comment = public dump
    	path = /home/shares/public
    	read only = No
    
    [bu_onen1]
    	path = /home/shares/bu_onen1
    	write list = vj928, vk594
    	read only = No
    
    [ptc]
    	path = /home/shares/bu_onen1/ptc
    	write list = proe
    	read only = No
    I noticed in the logs that I got the following error message when trying to view files, but it only showed up one time.
    Code:
    [2005/07/13 16:41:15, 0] auth/pampass.c:smb_pam_accountcheck(781)
      smb_pam_accountcheck: PAM: Account Validation Failed - Rejecting User KOBELCO_GA+vj928!
    I also need to point out that I have checked and double checked the files /etc/pam.d/samba and /etc/pam.d/system-auth and both appear to be ok. I would post those on here, but I"m currently at home and don't have access to the server.

  2. #2
    Linux User
    Join Date
    Jul 2005
    Posts
    369
    first of all can a normal user account log in to the system?

  3. #3
    Just Joined!
    Join Date
    Jun 2005
    Posts
    47
    Yes a normal user can log into the system. Also, a domain user can log into the system without an problems through gdm. The problem seems to be related to samba only.

  4. #4
    Just Joined!
    Join Date
    Jun 2005
    Posts
    47
    Ok, here is another update....

    I can write new directories and files to the file server from a windows xp machine, but I get an error message saying "Unable to create the folder/file" even though the folder/file are actually being written. However, I can not see the files from the windows xp machine. It's like I have write access an no read access.

  5. #5
    Just Joined!
    Join Date
    Jun 2005
    Posts
    47
    Ok this is weird....I moved my old smb.conf to smb.conf.old and rewrote a new one from scratch using swat and now everything works again! I used the exact same options! WTF?

  6. #6
    Linux User
    Join Date
    Jul 2005
    Posts
    369
    Do the users have sufficant permisions to access files.

  7. #7
    Linux Newbie
    Join Date
    Dec 2003
    Location
    Netherlands
    Posts
    193
    I known friend of mine had the same problems with Samba and FC4. On FC3 it worked perfectly without any errors. But after upgrading it had the same problems.

    I've wrote a new samba script, and it worked perfectly. Also know is the problem with the firewall. I disabled his firewall on FC4, which deliverd me hard time to work with FC4.

    I would not recommend to use FC4, but allright. If someone really likes FC than I can't say don't do it, but Debian is better to config
    Computers Are Like Air Conditioners... They\'re both useless with Windows open!

  8. #8
    Just Joined!
    Join Date
    Aug 2005
    Posts
    1

    Samba-3.0.14a has a bug with 'hide special files = Yes'

    HaMBoNE79: this is a flaw in samba, not in FC* nor any other distro. Tim Redman pointed this out in [1] (see there for bug case and solution). A bug was opened upstream, and closed [2].

    BTW: a better way to know how samba behaves is shown in [1], since smb.conf inspection doesn't offer a complete detail.

    [1] https://bugs.gentoo.org/show_bug.cgi?id=101770
    [2] https://bugzilla.samba.org/show_bug.cgi?id=2514

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •