Find the answer to your Linux question:
Results 1 to 3 of 3
I'm running SuSE 9.3 and attempting to get the Samba Server running. I have Windows 2000 boxes on a domain w/ an NT4 domain controller. I've gotten the Samba Server ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2005
    Posts
    49

    Samba Server "Incorrect username" error


    I'm running SuSE 9.3 and attempting to get the Samba Server running. I have Windows 2000 boxes on a domain w/ an NT4 domain controller. I've gotten the Samba Server to join the domain, and it appears in the Network Neighborhood. When I attempt to connect to it from Windows, I get:

    "incorrect password or unknown username..."

    I have users added to the smbusers and smbpasswd file. here's my smb.conf:

    # Samba config file created using SWAT
    # from 127.0.0.1 (127.0.0.1)
    # Date: 2005/07/05 13:19:55

    # Global parameters
    [global]
    workgroup = XYZ
    map to guest = Bad User
    username map = /etc/samba/smbusers
    printcap cache time = 750
    printcap name = cups
    logon path = \\%L\profiles\.msprofile
    logon drive = P:
    logon home = \\%L\%U\.9xprofile
    domain master = No
    wins server = eth0:192.168.X.X
    wins support = Yes
    idmap uid = 10000-20000
    idmap gid = 10000-20000
    printer admin = @ntadmin, root, administrator
    cups options = raw
    include = /etc/samba/dhcp.conf
    domain logons = No
    netbios name = linux
    security = domain
    password server = *
    passdb backend = smbpasswd
    log file = /etc/samba/%m.log
    log level = 1

    [homes]
    comment = Home Directories
    valid users = windows, user1
    read only = No
    inherit acls = Yes

    ## Share disabled by YaST
    # [profiles]
    # comment = Network Profiles Service
    # path = %H
    # read only = No
    # create mask = 0600
    # directory mask = 0700
    # store dos attributes = Yes

    [users]
    comment = All users
    path = /home
    read only = No
    inherit acls = Yes
    veto files = /aquota.user/groups/shares/
    valid users = windows, user1

    ## Share disabled by YaST
    # [groups]
    # comment = All groups
    # path = /home/groups
    # read only = No
    # inherit acls = Yes

    ## Share disabled by YaST
    # [printers]
    # comment = All Printers
    # path = /var/tmp
    # create mask = 0600
    # printable = Yes
    # browseable = No

    ## Share disabled by YaST
    # [print$]
    # comment = Printer Drivers
    # path = /var/lib/samba/drivers
    # write list = @ntadmin, root
    # force group = ntadmin
    # create mask = 0664
    # directory mask = 0775


    any ideas? thanks

  2. #2
    Linux Newbie
    Join Date
    Dec 2003
    Location
    Netherlands
    Posts
    193
    You can join a domain like this

    net join %domain% -UAdministrator

    Because of the case sensitivity of Linux you should watch for the uppercases.

    And why don't you make your Linux to be the domain controller. It's better and faster as NT4.

    And make then your NT4 machine a BDC(Backup Domain Controller)
    Computers Are Like Air Conditioners... They\'re both useless with Windows open!

  3. #3
    Just Joined!
    Join Date
    Jun 2005
    Posts
    49
    as i mentioned, the machine is already a member of the domain. for reasons i wont get into, i dont have the option of making the linux box the PDC. making it the PDC doesnt have anything to do with the issue, does it?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •