Find the answer to your Linux question:
Results 1 to 5 of 5
------------------- MY FILES'S LOCATION:- [root@dhcppc0 ~]# cd /var/ftp [root@dhcppc0 ftp]# ls -la drwxr-xr-x 2 paul paul 4096 Aug 6 04:39 pub [root@dhcppc0 ftp]# cd pub [[root@dhcppc0 pub]# ls -la total ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    40

    vsftpd -login but don't see files?


    -------------------
    MY FILES'S LOCATION:-
    [root@dhcppc0 ~]# cd /var/ftp
    [root@dhcppc0 ftp]# ls -la
    drwxr-xr-x 2 paul paul 4096 Aug 6 04:39 pub

    [root@dhcppc0 ftp]# cd pub
    [[root@dhcppc0 pub]# ls -la
    total 8
    -rw-r--r-- 1 paul paul 34 Aug 6 04:38 aaa
    -rw-r--r-- 1 paul paul 34 Aug 6 04:39 bbb
    [root@dhcppc0 pub]#
    --------------
    IN COMMAND LINE,
    I login ftp, ls
    appear below:-
    ftp>ls
    227 Entering Passive Mode (202,130,125,148,39,49)
    ftp: connect: Connection timed out
    ftp>

    what should I do next?

    --------------
    IN X-WINDOW
    when I go to
    ftp://userasswd@x.x.x.x

    I can see ftp://user@x.x.x.x, but can't see files in it.

  2. #2
    Linux Engineer Giro's Avatar
    Join Date
    Jul 2003
    Location
    England
    Posts
    1,219
    Have you looked in /var/log/vsftpd.log ?

  3. #3
    Just Joined!
    Join Date
    May 2005
    Posts
    97
    a couple of things.....

    1: is the server behind a firewall? are you behind this same firewall or on a dif. network?

    2: if you are no a diferent network and server is behind a firewall then you need to cnofigure passive mode if you are using nat.

    for example....
    say you have server running port 21 (default) well with passive mode you HAVE To set up data ports. by default VSFTPD uses tons and tons of data ports so you need to edit the vsftpd.conf file and tell it to use passive and you have to tell it what DATA ports to use and then forward those dataporst in your firewall.

    if both pcs are intenal then make sure to disable passive mode on your client.

    give us more info and we can help you a bit more, what you have given us is not sufficient at all to properly help you.

    Luma

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Aug 2005
    Posts
    40
    your pt 1 is my case. It is caused by my vsftpd behind firewall.

    Thanks!

  6. #5
    Just Joined!
    Join Date
    May 2005
    Posts
    97
    here is how I got mine going behind firewall..

    in the vsftpd.conf file I added this.
    pasv_enable=yes
    pasv_max_port=27210
    pasv_min_port=27200
    pasv_address=<your ip address> (without the <>) (external ip of your modem)

    I then set my router to foward port 21 to the server as well as port 27200 to 27200 to my server. ftp clients should be set to passive and voila should work (don't forget to restart vsftpd after changing the conf file)

    only downside is that every time your external ip changes you have to edit the file but mine is static so it has not been a problem.

    Luma

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •