Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 17 of 17
Sorry for the delay in posting back. I've been on a much needed (albeit short) vacation. The errors you're getting is because mysql isn't running. Try starting it with the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Oct 2005
    Posts
    4

    Sorry for the delay in posting back. I've been on a much needed (albeit short) vacation.

    The errors you're getting is because mysql isn't running. Try starting it with the following:

    Code:
    # /etc/init.d/mysql start
    See if that doesn't get you up and running.

  2. #12
    Linux Newbie exploder's Avatar
    Join Date
    Jun 2005
    Location
    127.0.0.1
    Posts
    164
    I get the same error:
    ERROR 2002: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)
    Registered Linux User#394486

  3. #13
    Just Joined!
    Join Date
    Oct 2005
    Posts
    4
    Hmm, that is a bit perplexing. I seem to remember I had to so something special to start mysql on my debian system but of course that was like 4 years ago and I've forgotten. When I get to work I'll see if I can dig up some notes about it.

    As a side note, I'm guessing you've googed that error message? Maybe add the distro & version (sarge, woody, etc) to it as well? Just a shot in the dark there. Will let you know what I find when I get to work.

  4. #14
    Just Joined!
    Join Date
    Oct 2005
    Posts
    4
    Ok, well I did find this in my notes here. This is for slackware 10, but may have some bearing on the situation because if memory serves me right, I had this same issue with debian and this solved it.

    Code:
    =========================
    to get mysql running on slackware 10.0
    # su mysql
    # mysql_install_db
    # /usr/bin/mysqld_safe &
    =========================
    Sorry, but I'm kinda grasping at straws here at the moment.

  5. #15
    Just Joined!
    Join Date
    Nov 2005
    Posts
    1
    I had the exact same problem. I see lots of people saying the same basic things over and over:
    = su root; /etc/init.d/mysql restart
    = reinstall mysql
    = build mysql from source

    None of which solved my problem.
    I've only seen two interesting solutions, the first one fixed my problem:

    = the loopback device was down; check first with ifconfig; if it's missing do a 'ifup lo'
    = check permissions on /tmp; should be 777

    I don't know how my loopback device went south, but that was my problem.

  6. #16
    Just Joined!
    Join Date
    Aug 2006
    Posts
    12
    Just so you know:

    /etc/init.d/mysql start

    is NOT the same thing as

    /etc/init.d/rc3.d/S90mysql start

    Even though the latter is a SYMLINK to the former! Yet the former doesn't work on my machine, but the latter does! How can that be?

  7. #17
    Just Joined!
    Join Date
    Apr 2007
    Posts
    18
    Hi there,

    In my case I solved the problem:
    ***
    050817 22:34:22 Can't start server: Bind on TCP/IP port: Cannot assign requested address
    050817 22:34:22 Do you already have another mysqld server running on port: 3306 ?
    ***

    in the following manner:

    Edit the file /etc/mysql/my.conf and find the section for bind-address and enter there your IP address.

    Cheers,

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •