Find the answer to your Linux question:
Results 1 to 6 of 6
Hi, I have a couple computers connected to a linksys router. One of the computers I want to use as a testing server, and as such I want to be ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    3

    Linux server not accepting IP through router


    Hi,

    I have a couple computers connected to a linksys router. One of the computers I want to use as a testing server, and as such I want to be able to type my IP in a browser (i.e. http://70.27.xxx.xxx/) and it would go to that testing server.

    I set my linksys router to forward ports 8080 and 80 to the static IP the server will be using of 192.168.1.101. The server is using fedora and the server is Apache Tomcat.

    I feel it has something to do with the routing in Fedora, but everything I try doesn't seem to work. I can connect to Apache from a browser in the server by typing the server's IP (i.e. http://192.168.1.101) but not when I type the main IP of 70.27.xxx.xxx,

    If anyone has any idea, please let me know.

    Thanks,
    papayiya
    Edit/Delete Message

  2. #2
    Linux Newbie jeickal's Avatar
    Join Date
    Jan 2005
    Location
    Switzerland
    Posts
    114
    can connect to Apache from a browser in the server by typing the server's IP (i.e. http://192.168.1.101) but not when I type the main IP of 70.27.xxx.xxx
    From where are you trying to connect to the server?
    I assume you have something like:

    LAN (192.168.1.x) <==> router (with PAT/NAT) <==> Internet

    if you configure your router to forward tcp 80 & 8080 request to the IP of your server, this will be applied only to traffic coming from the outside interface of your router (Internet side) going to the inside interface (LAN side). If you type http://192.168.1.101 from another PC on the LAN it works because you are directly connected (it won't even go throught the router). You need to test from the Internet to check that your PAT config is working.

  3. #3
    Just Joined!
    Join Date
    Aug 2005
    Posts
    3
    Hi,

    This is what I have:

    LAN (192.168.1.x) <==> router (with PAT/NAT) <==> Internet (70.27.xxx.xxx)

    My problem is that I need to access my server from an external computer. Your right, that from the router assigned IP I won't be able to get to my computer. But I want to get to that server by using my internet IP address.

    Any ideas?

  4. #4
    Linux Newbie jeickal's Avatar
    Join Date
    Jan 2005
    Location
    Switzerland
    Posts
    114
    What you're doing looks right. But how are you testing? From another connection to the Internet or from the same one? I'm wondering how the router will react if it get an attempt to connect to 70.27.xxx.xxx coming from it's internal side.. It might work but maybe you might want to try from a dial-up of from someone else connection. If it doesn't work you need to look at the log file of your apache server to see if you get any connection attempt. Or even better you can monitor the traffic reaching your server this way:
    Code:
    tcpdump tcp port 80
    You need to be root.
    Try locally (wih 192.168.1.101) first to see how the output of this command looks, and then try from the Internet. If you don't see any output of tcpdump, then it means there is sth wrong in the way you configure the PAT in your routers. You might wanna have a look at your router's log to try to understand what's wrong.
    I feel it has something to do with the routing in Fedora
    Your server is not doing any "routing" tasks. It only uses its default gateway (your router) to connect to the Internet. If you really don't see anything reaching your server, that looks like the router is not doing its job right. Also make sure you don't have a firewall on your server that could cause problems.

  5. #5
    Linux Newbie
    Join Date
    Jul 2005
    Location
    Turn Around
    Posts
    202
    for my linsys router I did this...

    192.168.1.1 in address bar... put in pass and username which both are "admin"as default.

    applications and gaming tab
    UPnP forwarding sub-tab
    make sure the HTTP row is set like this: TCP w/ int.port as 80. put in the correct IP to forward to (this could be ur problem.. sometimes it changes for me. use 'ifconfig' command on ur server box to see which IP to use). select the enable checkbox

    Save Settings at the bottom.

  6. #6
    Just Joined!
    Join Date
    Aug 2005
    Posts
    5
    Are you sure you configured the Fedora firewall to allow incoming requests on 8080?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •