Find the answer to your Linux question:
Results 1 to 5 of 5
I have the newest mysql (I got it by urpmi) and the latest phpbb. Everytime I try to use phpbb's install.php script I get this error: "The PHP configuration on ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Jan 2005
    Location
    Quebec, Canada
    Posts
    100

    mysql and phpbb


    I have the newest mysql (I got it by urpmi) and the latest phpbb.
    Everytime I try to use phpbb's install.php script I get this error: "The PHP configuration on your server doesn't support the database type that you chose"
    I would like to know if there is a specific way to setup mysql or my apache server, so I can get this working (I installed apache-mod_php, with urpmi as well).
    As you can tell, I'm a noob to this, but I want to learn, please help...

    -->Nikosapi

  2. #2
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    try creating a new file (in a web readable directory) in that file put:

    Code:
    <?phpinfo&#40;&#41;;?>
    save, then hit the page as though it were a website.

    Look in the resultant output for any MySQL related stuff.

    it hould have it's own section, and also be listed in the "Supported Types" in the "dbx" section (well, it is here, and it works ).

    also, did you setup a root password for MySQL? And also (i know this is stupid part with phpBB) did you setup a database for it to go into? I seem to remember that with phpBB you need to put a blank database there for it to install to!

    try running:

    Code:
    echo "create database <dbname>;" | mysql -u root -p
    That'll create a database called <dbname> for you using the root username/password. Then install to <dbname>
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  3. #3
    Linux Newbie
    Join Date
    Jan 2005
    Location
    Quebec, Canada
    Posts
    100
    Nope, that doesn't seem to work (although, the echo with the | is quite clever).
    It seems to me that the problem is that I can't connect to my mysql server with php.
    I tried this:
    Code:
    <?php
    if&#40;!&#40;$dbLink = mysql_connect&#40;"localhost", "nikosapi", "*******"&#41;&#41;&#41;
    &#123;
        print&#40;"Failed to connect to database!
    \n"&#41;;
        exit&#40;&#41;;
    &#125;
    ?>
    With no avail, it gives me this error: "Fatal error: Call to undefined function: mysql_connect() in /home/www/nikosapi/php/test.php on line 2"
    So, either my little php script is wrong or I have a configuration problem.
    Please help,

    -->Nikosapi

    P.S. The only place I see mysql on the .php page with <?phpinfo();?> in it is in the "Extensions listed here are (or will be soon) available as external modules. To install one or all of these, use "urpmi" php-EXTENSION_NAME" catergory, but I have mysql installed ( version 4.0.20 ) because I am able to create tables and add users from the terminal.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer jledhead's Avatar
    Join Date
    Oct 2004
    Location
    North Carolina
    Posts
    1,077
    Quote Originally Posted by Nikosapi
    but I have mysql installed ( version 4.0.20 ) because I am able to create tables and add users from the terminal.
    but have you enabled support for mysql in php? in my fedora distro I installed php and php-mysql, maybe there is a release for your distro?

  6. #5
    Linux Newbie
    Join Date
    Jan 2005
    Location
    Quebec, Canada
    Posts
    100
    that was the problem!
    thank you,
    -->Nikosapi

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •