Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
i have installed the Fedora core 4 today...i am trying to start the httpd server but whenever i tried by pressing the start button; it says failed to start the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    44

    problem on httpd


    i have installed the Fedora core 4 today...i am trying to start the httpd server
    but whenever i tried by pressing the start button; it says failed to start the
    server. naturally it should report any error with line number if there is one in
    the httpd.conf file but it just saying failed to start server.

    i have configure httpd.conf this way:
    Listen 127.0.0.1:80




    ServerAdmin root@localhost
    ServerName root:80

    for your information i am using the default fire wall...

    please help!

  2. #2
    Linux Engineer
    Join Date
    Aug 2004
    Posts
    826
    Code:
    # /etc/init.d/httpd start

  3. #3
    Just Joined!
    Join Date
    May 2005
    Posts
    44
    it's all the same shouldn't be? i have tried to start the httpd server by Desktop->System Settings->Server Settings-> Services->then selected httpd and click on start button.

    but still it didnt work.
    however i have tried by your code and put it into the httpd.conf but still no result!
    any idea?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    May 2005
    Posts
    44
    here's typo correction.... i meant to say... i have tried your code on the shell(instead of httpd.conf) but still it doesnt worked!

  6. #5
    Linux Engineer jledhead's Avatar
    Join Date
    Oct 2004
    Location
    North Carolina
    Posts
    1,077
    if it doesn't report any errors when starting, are there any errors in your log files?

  7. #6
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    you might have it set as a default service, in which case it would be running on boot up...try to restart it instead of starting it with

    Code:
    service httpd restart
    or
    Code:
    service httpd stop
    service httpd start
    do you get an OK or a FAILED?
    Operating System: GNU Emacs

  8. #7
    Linux Engineer
    Join Date
    Aug 2004
    Posts
    826
    Quote Originally Posted by hassanLinux
    it's all the same shouldn't be? i have tried to start the httpd server by Desktop->System Settings->Server Settings-> Services->then selected httpd and click on start
    The reason I told you to enter the command was so that we could see more verbose output.

  9. #8
    Just Joined!
    Join Date
    Sep 2005
    Posts
    2

    Re: problem on httpd

    Quote Originally Posted by hassanLinux
    i have installed the Fedora core 4 today...i am trying to start the httpd server
    but whenever i tried by pressing the start button; it says failed to start the
    server. naturally it should report any error with line number if there is one in
    the httpd.conf file but it just saying failed to start server.

    i have configure httpd.conf this way:
    Listen 127.0.0.1:80

    please help!
    Why don't you start the server using apachectl command?
    You need to log in as root, then type
    apachectl start
    To stop the server type
    apachectl stop.

    You might need to locate the command if the path is not defined in the start up script
    e.g. this way:
    #find / -name apachectl

  10. #9
    Just Joined!
    Join Date
    Sep 2005
    Posts
    8

    Re: problem on httpd

    Quote Originally Posted by hassanLinux
    i have installed the Fedora core 4 today...i am trying to start the httpd server
    but whenever i tried by pressing the start button; it says failed to start the
    server. naturally it should report any error with line number if there is one in
    the httpd.conf file but it just saying failed to start server.

    i have configure httpd.conf this way:
    Listen 127.0.0.1:80




    ServerAdmin root@localhost
    ServerName root:80

    for your information i am using the default fire wall...

    please help!

    check /var/log/audit/audit.log or /var/log/messages to see the errmsg httpd gives you when you try to start httpd.

  11. #10
    Just Joined!
    Join Date
    Sep 2005
    Posts
    1

    Me, too

    I just built a new Fedora Core 4 machine, and am having a similar problem. starting httpd using /usr/sbin/apachectl start works just fine, but starting it with /etc/init.d/http start gives me this:
    Starting httpd: [Failed]

    I tried running it with sh - x and I didn't see any obvious errors.

    I'd be perfectly happy with using apachectl, but for some reason, even if I put a link named S99httpd that points to it in /etc/rc3.d, apache doesn't start during boot.
    [/code]

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •