Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 12 of 12
Originally Posted by genesus I have set my registrar to forward my domain, www.johntennyson.com , to my home ip, which currently is 69.86.84.137 -- technically this is a dynamic ip; ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Sep 2005
    Posts
    8

    Re: Can't get online, what do I do? Apache and httpd?


    Quote Originally Posted by genesus
    I have set my registrar to forward my domain, www.johntennyson.com, to my home ip, which currently is
    69.86.84.137 -- technically this is a dynamic ip; however, it hardly ever changes so I am treating
    it as a static ip and can always change the forwarding later on.

    I have apache set to listen to all available adresses on port 80, so that I can have my router
    forward to my local server as there are many machines on my local network.

    I have my router setup in the port forwarding section to forward the HTTP (service name) to the
    local ip of my machine (192.168.0.2) with the start and end ports of 80.

    Results: not too good really, when I start apache with /etc/init.d/httpd start, it starts. OK, good
    for now. When I point any browser that is connected through our router to the local ip address of
    the server (192.168.0.2) then I see the web page that I want the world to see. Good Again.

    The bad stuff . When I try to enter my ip manually in any browser I get a message reading: "The
    connection was refused when attempting to contact 68.86.84.137." The really strange part, though,
    is that when I attempt to connect to www.johntennyson.com--and you guys can check this out and tell
    me if I'm wrong--that it says connecting, transferring data; however, no webpage is displayed, and
    no connection refused message.

    Ok I've read alot about port 80 being blocked by the isp, which I can check and it seems to be
    blocked; however, with the above setup, what can I do to change to a different port. I am new to
    server setups and don't know what it means to use 8080 or another port. Not sure how to turn them
    on and assign them, etc. When I run the command "nmap -p 80 69.86.84.137 I get a message that the
    port is closed". When I run "nmap -sT 69.86.84.137" I see that the only open port is 5432 running
    the postgres service...hmmm. When I run "nmap -p 80 192.168.0.2" for my local ip address I see that
    port 80 is up and running.

    Can anyone help me getting my site online. I really don't understand why this isn't working.

    Although, I think that it might be a problem with how I set my router, because I see the
    sight with local IP...

    Thanks for your help...

    john
    Quote Originally Posted by gusc
    I have had the same problem. If you wanne C your own website you will have to setup a local DNS with an entry for your url returning your INTERNAL ip-adres.

  2. #12
    Just Joined!
    Join Date
    Sep 2005
    Posts
    8

    Re: Can't get online, what do I do? Apache and httpd?

    Quote Originally Posted by genesus
    I have set my registrar to forward my domain, www.johntennyson.com, to my home ip, which currently is
    69.86.84.137 -- technically this is a dynamic ip; however, it hardly ever changes so I am treating
    it as a static ip and can always change the forwarding later on.

    I have apache set to listen to all available adresses on port 80, so that I can have my router
    forward to my local server as there are many machines on my local network.

    I have my router setup in the port forwarding section to forward the HTTP (service name) to the
    local ip of my machine (192.168.0.2) with the start and end ports of 80.

    Results: not too good really, when I start apache with /etc/init.d/httpd start, it starts. OK, good
    for now. When I point any browser that is connected through our router to the local ip address of
    the server (192.168.0.2) then I see the web page that I want the world to see. Good Again.

    The bad stuff . When I try to enter my ip manually in any browser I get a message reading: "The
    connection was refused when attempting to contact 68.86.84.137." The really strange part, though,
    is that when I attempt to connect to www.johntennyson.com--and you guys can check this out and tell
    me if I'm wrong--that it says connecting, transferring data; however, no webpage is displayed, and
    no connection refused message.

    Ok I've read alot about port 80 being blocked by the isp, which I can check and it seems to be
    blocked; however, with the above setup, what can I do to change to a different port. I am new to
    server setups and don't know what it means to use 8080 or another port. Not sure how to turn them
    on and assign them, etc. When I run the command "nmap -p 80 69.86.84.137 I get a message that the
    port is closed". When I run "nmap -sT 69.86.84.137" I see that the only open port is 5432 running
    the postgres service...hmmm. When I run "nmap -p 80 192.168.0.2" for my local ip address I see that
    port 80 is up and running.

    Can anyone help me getting my site online. I really don't understand why this isn't working.

    Although, I think that it might be a problem with how I set my router, because I see the
    sight with local IP...

    Thanks for your help...

    john
    I have had the same problem. If you wanne C your own website you will have to setup a local DNS with an entry for your url returning your INTERNAL ip-adres.

    Another option is configure (in /etc/http/conf/httpd.conf) an extra virtual host like this:

    # change the IP into your inside IP!
    <VirtualHost 192.168.0.1:80>
    ServerAdmin webmaster@domain.com
    DocumentRoot /var/www/html/your_website
    Servername www.domain.com
    </VirtualHost>


    Do not forget to uncomment the line that says "NameVirtualHost *:80"

    Cheers

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •