Find the answer to your Linux question:
Results 1 to 2 of 2
I have created a RAID 1 array using Ubuntu Linux. I installed a graphical base system (by default) opposed to entering 'server' at the install disc boot prompt. Both my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2005
    Location
    Tokyo, Japan
    Posts
    1

    Ubuntu Server with Samba, Windows PC's cant access server!


    I have created a RAID 1 array using Ubuntu Linux. I installed a graphical base system (by default) opposed to entering 'server' at the install disc boot prompt. Both my arrays have 160 GB hard drives and are correctly syncing:

    code:

    # cat /proc/mdstat


    quote:Personalities : [raid1]
    md0 : active raid1 hdb1[0] hda1[1]
    159332544 blocks [2/2] [UU]

    unused devices: <none>



    I then:

    code:

    # nmbd
    #smbd



    I then created my users:

    code:

    # adduser bob



    I then ran:

    code:

    # smbpasswd



    I then edited /etc/samba/smb.conf:

    (Comments removed for clarity, "Network Data" is the folder I would like to share on the server, as well as the user's respective home's)

    quote:#

    #Global Settings

    [global]
    workgroup = NETWORK
    server string = Network Data
    ; wins support = no
    ; wins server = w.x.y.z
    ; name resolve order = lmhosts host wins bcast

    #### Debugging/Accounting ####

    log file = /var/log/samba/log.%m
    max log size = 1000
    ; syslog only = no
    syslog = 0
    panic action = /usr/share/samba/panic-action %d
    ####### Authentication #######

    security = user
    encrypt passwords = true
    passdb backend = tdbsam guest
    obey pam restrictions = yes
    ; guest account = nobody
    invalid users = root
    ; unix password sync = no
    passwd program = /usr/bin/passwd %u
    passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .
    ; pam password change = no

    ########## Printing ##########

    ; load printers = yes
    ; printing = bsd
    ; printcap name = /etc/printcap
    ; printing = cups
    ; printcap name = cups
    ; printer admin = @ntadmin

    ######## File sharing ########

    # Name mangling options
    ; preserve case = yes
    ; short preserve case = yes
    wins support = no

    [Network Data]
    public = no
    comment = Data
    path = /home/network
    writable = yes
    printable = no
    valid users = billy bob bart bud
    create mask = 0775
    directory mask = 0775

    ############ Misc ############

    socket options = TCP_NODELAY
    ; message command = /bin/sh -c '/usr/bin/linpopup "%f" "%m" %s; rm %s' &
    ; domain master = auto
    ; idmap uid = 10000-20000
    ; idmap gid = 10000-20000
    ; template shell = /bin/bash

    #Share Definitions
    available = yes
    browseable = no
    public = yes
    [homes]
    comment = Home Directories
    browseable = yes
    writable = yes
    create mask = 0775
    directory mask = 0775
    [netlogon]
    ; comment = Network Logon Service
    ; path = /home/samba/netlogon
    ; guest ok = yes
    ; writable = no
    ; share modes = no
    [printers]
    comment = All Printers
    browseable = no
    path = /tmp
    printable = yes
    public = no
    writable = no
    create mode = 0700
    [print$]
    comment = Printer Drivers
    path = /var/lib/samba/printers
    browseable = yes
    read only = yes
    guest ok = no
    ; write list = root, @ntadmin
    [cdrom]
    ; comment = Samba server's CD-ROM
    ; writable = no
    ; locking = no
    ; path = /cdrom
    ; public = yes
    ; preexec = /bin/mount /cdrom
    ; postexec = /bin/umount /cdrom



    After editing smb.conf I then restarted samba with:

    code:

    sudo /etc/init.d/samba restart



    My windows clients can see the server (Samba is running) but no prompt is given for password, I'm just not allowed to use 'this resource'.

    Any suggestions?

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,845
    Did you run smbpassword for each user to set their password to be the same as their windows one? You also have to edit /etc/samba/passwd file to make an entry for each user with room to insert the password hash into before you run smbpasswd, something a bit like this:

    Code:
    <username>&#58;<userid>&#58;XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX&#58;XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX&#58;&#91;UD         &#93;&#58;LCT-00000000&#58;
    Linux user #126863 - see http://linuxcounter.net/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •