Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 25
That's my first time ever trying to host a website on my PC. While I can see the html file when I type http://127.0.0.1/ or when I type my IP ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2005
    Posts
    23

    setting up web server - NOOB Q


    That's my first time ever trying to host a website on my PC. While I can see the html file when I type http://127.0.0.1/ or when I type my IP http://xx.x.x.xxx/, other people tell me they cannot access the site.

    I seem to have installed Apache correctly - it was confirmed by a console message I got. I also have Webmin installed as I read somewhere it is useful.

    I just don't know where to start. How, for example am I to check whether the site is 'visible' on the net? It is not, and I have no idea what I'm doing wrong. I've looked at httpd.conf file, but being a noob I don't know what to edit there.

    I'd appreciate some step by step tips. Not everyone started off as a guru. THANKS!

  2. #2
    Just Joined!
    Join Date
    Sep 2005
    Location
    Waterford Irl.
    Posts
    17
    Same here.I have been going round in circles for the last few hours trying get a few simple instructions to get me started.Thanks in advance to any kind person who will take pity on me and times

  3. #3
    Linux Newbie
    Join Date
    Jul 2005
    Location
    ~/home
    Posts
    105
    is the server directly connected to the internet,
    or is it behind a router?

    in case it's behind a router, search google for portforwarding.
    Help me getting a Opera licence
    Beginning with debian? -> read THIS!

  4. #4
    Linux Newbie
    Join Date
    Jul 2005
    Location
    Turn Around
    Posts
    202
    if its behind a firewall or router u must allow traffic thru port 80 with port forwarding

    keep in mind some IPSs dont allow port 80 to be used to hosting websites

  5. #5
    Just Joined!
    Join Date
    Sep 2005
    Location
    Waterford Irl.
    Posts
    17
    Thanks both, I think my problem is with the darned ISP, will check with them Monday.

  6. #6
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    you can always change to port 8080, usually the isp will not block that high, also make sure you reload httpd whenever you change settings, and set up portforwarding to the correct station on the router.
    Operating System: GNU Emacs

  7. #7
    Just Joined!
    Join Date
    Jul 2005
    Posts
    23
    Quote Originally Posted by genesus
    you can always change to port 8080, and set up portforwarding to the correct station on the router.
    How do I do that
    I have a direct connection to the Internet, I think. It's a LAN connection, which means I have Internet access as soon as my PC boots. Thank you.

  8. #8
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    well, before you do do that call your isp and make sure that they do in fact block port 80. Then with your registrar forward the domain to your ip with :8080 after it...so if you are bill.com, you would use bill.com:8080...and you would have to configure apache through httpd.conf to use 8080, you can make sure that you open the port correctly with
    Code:
    nmap -sT localhost
    It is still kind of rare that isps will block 80, so run the above command and make sure that it is open on your end...also in httpd.conf what does your line that has "listen" look like?
    Operating System: GNU Emacs

  9. #9
    Just Joined!
    Join Date
    Jul 2005
    Posts
    23
    Quote Originally Posted by genesus
    Code:
    nmap -sT localhost
    This returns the following:

    Code:
    (The 1654 ports scanned but not shown below are in state: closed)
    PORT      STATE SERVICE
    21/tcp    open  ftp
    25/tcp    open  smtp
    80/tcp    open  http
    111/tcp   open  rpcbind
    443/tcp   open  https
    631/tcp   open  ipp
    1013/tcp  open  unknown
    6000/tcp  open  X11
    10000/tcp open  snet-sensor-mgmt
    
    Nmap finished: 1 IP address (1 host up) scanned in 0.357 seconds
    Quote Originally Posted by genesus
    also in httpd.conf what does your line that has "listen" look like?
    I haven't changed any settings here, here's what I have:

    Code:
    <IfDefine APACHEPROXIED>
        Port 8080
        Listen 8080
    </IfDefine>
    <IfDefine !APACHEPROXIED>
        Port 80
        Listen 80
    </IfDefine>
    What else should I configure to have my site up and running? Thanks in advance.

  10. #10
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    ok, everything looks good; however, if you want to use port 8080, nmap is not detecting it as open, but it does have port 80 open...what is the site, so we can try to get to it and see the error message?
    Operating System: GNU Emacs

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •