Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Apache compilation problem--Pls help me Im stuch : (

    Hi gurus out there,

    Kindly help me in solving my problem. My already stuck for a week now. I've visited many mailing list but cant find solutions to my BIG, BIG PROBLEM!

    I'am installing an apache-1.3.28 on my RH9.0 with 2.4.22 kernel.

    #SSL_BASE=SYSTEM EAPI_MM=SYSTEM OPTIM="-O3 -march=i686 -mcpu=i686 -funroll-loops -fomit-frame-pointer" CFLAGS="-DDYNAMIC_MODULE_LIMIT=0" ./configure --prefix=/var/www --bindir=/usr/bin --sbindir=/usr/sbin --libexecdir=/usr/lib/apache --includedir=/usr/include/apache --sysconfdir=/etc/httpd/conf --localstatedir=/var --runtimedir=/var/run --logfiledir=/var/log/httpd --datadir=/var/www --proxycachedir=/var/cache/httpd --mandir=/usr/share/man --add-module=src/modules/experimental/mod_mmap_static.c --add-module=src/modules/standard/mod_auth_db.c --enable-module=ssl --enable-rule=SSL_SDBM --disable-rule=SSL_COMPAT --activate-module=src/modules/php4/libphp4.a --enable-module=php4 --activate-module=src/modules/perl/libperl.a --enable-module=perl --disable-module=status --disable-module=userdir --disable-module=negotiation --disable-module=autoindex --disable-module=imap --server-uid=www --server-gid=www

    # OK, Here everything turned out alright. However running...


    gcc -c -I../.. -I/usr/lib/perl5/5.8.0/i386-linux-thread-multi/CORE -I../../os/unix -I../../include -O3 -march=i686 -mcpu=i686 -funroll-loops -fomit-frame-pointer -DLINUX=22 -DMOD_SSL=208115 -I/var/tmp/php-4.2.3 -I/var/tmp/php-4.2.3/main -I/var/tmp/php-4.2.3/main -I/var/tmp/php-4.2.3/Zend -I/var/tmp/php-4.2.3/Zend -I/var/tmp/php-4.2.3/TSRM -I/var/tmp/php-4.2.3/TSRM -I/var/tmp/php-4.2.3 -DMOD_PERL -DUSE_PERL_SSI -D_REENTRANT -DTHREADS_HAVE_PIDS -DDEBUGGING -fno-strict-aliasing -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -DEAPI -DEAPI_MM -DNO_DL_NEEDED -DDYNAMIC_MODULE_LIMIT=0 `../../apaci` mod_auth.c
    gcc -c -I../.. -I/usr/lib/perl5/5.8.0/i386-linux-thread-multi/CORE -I../../os/unix -I../../include -O3 -march=i686 -mcpu=i686 -funroll-loops -fomit-frame-pointer -DLINUX=22 -DMOD_SSL=208115 -I/var/tmp/php-4.2.3 -I/var/tmp/php-4.2.3/main -I/var/tmp/php-4.2.3/main -I/var/tmp/php-4.2.3/Zend -I/var/tmp/php-4.2.3/Zend -I/var/tmp/php-4.2.3/TSRM -I/var/tmp/php-4.2.3/TSRM -I/var/tmp/php-4.2.3 -DMOD_PERL -DUSE_PERL_SSI -D_REENTRANT -DTHREADS_HAVE_PIDS -DDEBUGGING -fno-strict-aliasing -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -DEAPI -DEAPI_MM -DNO_DL_NEEDED -DDYNAMIC_MODULE_LIMIT=0 `../../apaci` mod_auth_db.c
    mod_auth_db.c: In function `get_db_pw':
    mod_auth_db.c:175: warning: passing arg 2 of pointer to function from incompatible pointer type
    mod_auth_db.c:175: warning: passing arg 4 of pointer to function makes pointer from integer without a cast
    mod_auth_db.c:175: error: too few arguments to function
    make[4]: *** [mod_auth_db.o] Error 1
    make[3]: *** [all] Error 1
    make[2]: *** [subdirs] Error 1
    make[2]: Leaving directory `/var/tmp/apache_1.3.28/src'
    make[1]: *** [build-std] Error 2
    make[1]: Leaving directory `/var/tmp/apache_1.3.28'
    make: *** [build] Error 2

    Along with my installation, I had compiled successfully the following:


    The following are installed by rpm:

    -gdbm- and devel

    Pls help me...plsss...
    Really need your expert advise.

    A million thanks in advance

  2. #2
    Linux Engineer Giro's Avatar
    Join Date
    Jul 2003
    Firstly things installed by the admin normally go in /usr/local. You shouldnt need to add php4 as a module when compiling Apache it will be added when you compile PHP. You also dont realy need --server-uid=www --server-gid=www cause you set them in the .conf file.

    And i beleve this --add-module=src/modules/standard/mod_auth_db.c should look like this --enable-module=mod_auth_db, Also Imap is disabled by default IIRC.

    And this --activate-module=src/modules/perl/libperl.a should look like this --enable-module=cgi.

    Try this (You will note that i have made it more readable) ->
    export SSL_BASE=SYSTEM EAPI_MM=SYSTEM OPTIM="-O3 -march=i686 -mcpu=i686 -funroll-loops -fomit-frame-pointer" CFLAGS="-DDYNAMIC_MODULE_LIMIT=0"
    ./configure \
    --prefix=/var/www \
    --bindir=/usr/bin \
    --sbindir=/usr/sbin \
    --libexecdir=/usr/lib/apache \
    --includedir=/usr/include/apache \
    --sysconfdir=/etc/httpd/conf \
    --localstatedir=/var \
    --runtimedir=/var/run \
    --logfiledir=/var/log/httpd \
    --datadir=/var/www \
    --proxycachedir=/var/cache/httpd \
    --mandir=/usr/share/man \
    --enable-module=mod_mmap_static \
    --enable-module=mod_auth_db  \
    --enable-module=ssl \
    --enable-rule=SSL_SDBM \
    --disable-rule=SSL_COMPAT  \
    --enable-module=cgi \
    --disable-module=status \
    --disable-module=userdir \
    --disable-module=negotiation \
    --disable-module=autoindex \
    --disable-module=imap \
    --server-uid=www \
    Forgot: Also you should compile PHP after you have compiled Apache.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts