Find the answer to your Linux question:
Results 1 to 5 of 5
HI, plz I need help . below is my network . --- 202.x.x.x -- |linux NAT server| --- 10.0.0.x lan i installed qmail on 10.0.0.10 (local), it can receive mails ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2003
    Posts
    19

    qmail behind nat - can get mails but can't send * i googled



    HI,

    plz I need help . below is my network .

    --- 202.x.x.x -- |linux NAT server| --- 10.0.0.x lan

    i installed qmail on 10.0.0.10 (local), it can receive mails from other internet servers like yahoo!! etc.When ever i tried to send mail , iam getting error message in log file

    *****!!! I searched in google for below error , i got too
    much info to understand , thats y iam asking you again here.
    ***** !!!

    Oct 22 13:41:04 big2all qmail: 1066844464.755443 starting delivery 31: msg 501365 to remote ehpserver@yahoo.com
    Oct 22 13:41:04 big2all qmail: 1066844464.756311 status: local 0/10 remote 1/20
    Oct 22 13:41:04 big2all qmail: 1066844464.795894 delivery 31: deferral: CNAME_lookup_failed_temporarily._(#4.4.3)/
    Oct 22 13:41:04 big2all qmail: 1066844464.796213 status: local 0/10 remote 0/20
    Oct 22 13:44:41 big2all qmail: 1066844681.796139 starting delivery 32: msg 501371 to remote CNET_Networks_#3.107880.313136393635303836.b@newsl etters.online.com
    Oct 22 13:44:41 big2all qmail: 1066844681.797002 status: local 0/10 remote 1/20
    Oct 22 13:44:41 big2all qmail: 1066844681.823117 delivery 32: deferral: CNAME_lookup_failed_temporarily._(#4.4.3)/

    **** My dns is working fine , dig commadn working fine.
    but y above error is comming ? is there any special work
    to do to run qmail behind nat ???

    -thanks for your time .

  2. #2
    Linux Engineer
    Join Date
    Sep 2003
    Location
    Knoxhell, TN
    Posts
    1,078
    is the nat box a router? do you have the mail ports open through port forwarding?
    Their code will be beautiful, even if their desks are buried in 3 feet of crap. - esr

  3. #3
    Just Joined!
    Join Date
    Oct 2003
    Posts
    19
    yes , that is router and iam already running http,ftp from my local lan pc ( 10.0.0.x). all services working fine and accessable from outer side world. all ports (like 80,110,25) forwarded correctly.My problem only with qmail ( i can get mails , but iam unable to send)

  4. #4
    Linux Engineer
    Join Date
    Sep 2003
    Location
    Knoxhell, TN
    Posts
    1,078
    have you read the qmail manual? or a faq?
    Their code will be beautiful, even if their desks are buried in 3 feet of crap. - esr

  5. #5
    Just Joined!
    Join Date
    Oct 2003
    Posts
    19
    yup , i read all of them . any help!! plz

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •