Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
Ok, I have been obsessive trying to set up a server with no success. I would like to run it Linux but I have so far just tried on windows. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    88

    Trouble With a ISP


    Ok, I have been obsessive trying to set up a server with no success. I would like to run it Linux but I have so far just tried on windows. I have made a FTP that works internally but when I try to port forward it doesnít work. I have a qwest actiontec router/access point and I am not sure whether it is actually forwarding my ports or not. Also I though that I might be getting my ports blocked by qwest, Is there a way to check whether my ports are open? So I need to get another router? Ohh yea I have a dynamic ip so that might be some trouble but I thought that it would just work until my ip changed and I donít know if that is the problem. I would appreciated any input possible

  2. #2
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    A few things for you to try...

    1) I run servers on dynamic ip addresses just fine, you only have to change a few things when your ip changes, if you are running ftp you just have to point your client to the new ip.

    2) When you have your ftpd, whichever one you're using, running then you can run
    Code:
    nmap -sT localhost
    to view which of your ports are open, you should generally see port 21 open for ftp, port 22 for ssh, port 23 for telnet, and port 80 for http, if you are running all of these types of servers.

    3) Set your router to port forwarding on the correct port and the correct local route, make sure you send the requests to the right machines, my router's local ip is 168.192.0.1, so if I server ftp on a machine that the router registers as 168.192.0.3 I need to forward ftp requests to port 21 on 192.168.0.3. Some routers assign numbers dynamically on reboot; however, you can bind the number to a particular machine through your routers tools.

    4) After this you will be able to ftp...to test this try two things, from your local network, from any of the computers hooked up to your router you would, if the above variables are correct for you ftp 192.168.0.3, you will not be able to ftp to your ip address from within the router--which is just the way that routers work. From outside of your local network you can ftp to your dynamic ip and it should work...if you are unsure of just what your ip is, point your browser to www.whatismyip.com, and point to the ip that displays.

    5) You may also run into some problems in your ftp conf file, vsftpd.conf if you use vsftpd to serve ftp requests. It is my default disabled and you should really look at the file and configure it correctly...it is very well commented and pretty self-intuitive. Make sure that after changes you either reload the vsftpd or stop and then start it again to use the new conf file.

    Post back with any problems...
    Operating System: GNU Emacs

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Posts
    88
    root@ubuntu:/home/eric # nmap -sT localhost
    bash: nmap: command not found
    root@ubuntu:/home/eric #


    That comes up when I try to do the "nmap -sT local host" commmand

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    you will need to install nmap then, you should be able to get it through apt-get, if you have it enabled, if not then look up the ubuntu faq and enable it, its indespensible for a debian based distro.
    Operating System: GNU Emacs

  6. #5
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,934
    If you're logged on as a user and used 'su' to change to root, then you might not have the paths to your executables set up correctly, and this is the kind of response you might get.

    Use 'su -' to change to root, and you'll have the full root environment, including the executable paths.

    I believe this may be the problem here because you're logged on as root in your user directory. This is a tell-tale sign that you used just 'su' to change to root.
    Linux user #126863 - see http://linuxcounter.net/

  7. #6
    Just Joined!
    Join Date
    Feb 2005
    Posts
    88
    Code:
    Starting nmap 3.75 ( http://www.insecure.org/nmap/ ) at 2005-10-08 14:50 CDT
    Interesting ports on localhost.localdomain (127.0.0.1):
    (The 1659 ports scanned but not shown below are in state: closed)
    PORT     STATE SERVICE
    21/tcp   open  ftp
    25/tcp   open  smtp
    631/tcp  open  ipp
    5900/tcp open  vnc
    
    Nmap run completed -- 1 IP address (1 host up) scanned in 1.078 seconds

  8. #7
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    ok, your port is open correctly, can you ftp to localhost, or have a friend try to ftp to your ip?
    Operating System: GNU Emacs

  9. #8
    Just Joined!
    Join Date
    Feb 2005
    Posts
    88
    I type
    Code:
    ftp localhost
    right?

  10. #9
    Just Joined!
    Join Date
    Feb 2005
    Posts
    88
    Code:
    eric@ubuntu:~$ ftp localhost
    Connected to localhost.localdomain.
    220 (vsFTPd 2.0.1)
    Name (localhost:eric): eric
    530 This FTP server is anonymous only.
    Login failed.
    ftp>

  11. #10
    Just Joined!
    Join Date
    Feb 2005
    Posts
    88
    Here is my vsftpd config file
    Code:
    # Example config file /etc/vsftpd.conf
    #
    # The default compiled in settings are fairly paranoid. This sample file
    # loosens things up a bit, to make the ftp daemon more usable.
    # Please see vsftpd.conf.5 for all compiled in defaults.
    #
    # READ THIS: This example file is NOT an exhaustive list of vsftpd options.
    # Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
    # capabilities.
    #
    #
    # Run standalone?  vsftpd can run either from an inetd or as a standalone
    # daemon started from an initscript.
    listen=YES
    #
    # Run standalone with IPv6?
    # Like the listen parameter, except vsftpd will listen on an IPv6 socket
    # instead of an IPv4 one. This parameter and the listen parameter are mutually
    # exclusive.
    #listen_ipv6=YES
    #
    # Allow anonymous FTP? (Beware - allowed by default if you comment this out).
    anonymous_enable=YES
    #
    # Uncomment this to allow local users to log in.
    #local_enable=YES
    #
    # Uncomment this to enable any form of FTP write command.
    #write_enable=YES
    #
    # Default umask for local users is 077. You may wish to change this to 022,
    # if your users expect that (022 is used by most other ftpd's)
    #local_umask=022
    #
    # Uncomment this to allow the anonymous FTP user to upload files. This only
    # has an effect if the above global write enable is activated. Also, you will
    # obviously need to create a directory writable by the FTP user.
    #anon_upload_enable=YES
    #
    # Uncomment this if you want the anonymous FTP user to be able to create
    # new directories.
    #anon_mkdir_write_enable=YES
    #
    # Activate directory messages - messages given to remote users when they
    # go into a certain directory.
    dirmessage_enable=YES
    #
    # Activate logging of uploads/downloads.
    xferlog_enable=YES
    #
    # Make sure PORT transfer connections originate from port 20 (ftp-data).
    connect_from_port_20=YES
    #
    # If you want, you can arrange for uploaded anonymous files to be owned by
    # a different user. Note! Using "root" for uploaded files is not
    # recommended!
    #chown_uploads=YES
    #chown_username=whoever
    #
    # You may override where the log file goes if you like. The default is shown
    # below.
    #xferlog_file=/var/log/vsftpd.log
    #
    # If you want, you can have your log file in standard ftpd xferlog format
    #xferlog_std_format=YES
    #
    # You may change the default value for timing out an idle session.
    #idle_session_timeout=600
    #
    # You may change the default value for timing out a data connection.
    #data_connection_timeout=120
    #
    # It is recommended that you define on your system a unique user which the
    # ftp server can use as a totally isolated and unprivileged user.
    #nopriv_user=ftpsecure
    #
    # Enable this and the server will recognise asynchronous ABOR requests. Not
    # recommended for security (the code is non-trivial). Not enabling it,
    # however, may confuse older FTP clients.
    #async_abor_enable=YES
    #
    # By default the server will pretend to allow ASCII mode but in fact ignore
    # the request. Turn on the below options to have the server actually do ASCII
    # mangling on files when in ASCII mode.
    # Beware that turning on ascii_download_enable enables malicious remote parties
    # to consume your I/O resources, by issuing the command "SIZE /big/file" in
    # ASCII mode.
    # These ASCII options are split into upload and download because you may wish
    # to enable ASCII uploads (to prevent uploaded scripts etc. from breaking),
    # without the DoS risk of SIZE and ASCII downloads. ASCII mangling should be
    # on the client anyway..
    #ascii_upload_enable=YES
    #ascii_download_enable=YES
    #
    # You may fully customise the login banner string:
    #ftpd_banner=Welcome to blah FTP service.
    #
    # You may specify a file of disallowed anonymous e-mail addresses. Apparently
    # useful for combatting certain DoS attacks.
    #deny_email_enable=YES
    # (default follows)
    #banned_email_file=/etc/vsftpd.banned_emails
    #
    # You may restrict local users to their home directories.  See the FAQ for
    # the possible risks in this before using chroot_local_user or
    # chroot_list_enable below.
    #chroot_local_user=YES
    #
    # You may specify an explicit list of local users to chroot() to their home
    # directory. If chroot_local_user is YES, then this list becomes a list of
    # users to NOT chroot().
    #chroot_list_enable=YES
    # (default follows)
    #chroot_list_file=/etc/vsftpd.chroot_list
    #
    # You may activate the "-R" option to the builtin ls. This is disabled by
    # default to avoid remote users being able to cause excessive I/O on large
    # sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
    # the presence of the "-R" option, so there is a strong case for enabling it.
    #ls_recurse_enable=YES
    When I try to edit it, it wont let me because it says it is read only. Do you know how to change to root to open the file?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •