Find the answer to your Linux question:
Results 1 to 4 of 4
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    apache / file permission issues?

    Well I ran apache on my ubuntu desktop for quite some time and seemed to have no issues with file permissions after i moved the files into the www directory anyway now I have recently rebuilt a 1ghz p3 machine to run as my server.... as you can see by clicking that, the permissions are not set correctly. I tried by changing the files to allow others read access before moving them to the server but it didnt help. any suggestions?[/url]

  2. #2
    Linux User yourname3232's Avatar
    Join Date
    Aug 2005
    Pacific Northwest, USA
    Have you tried setting the user to apache and group apache?
    Registered GNU/Linux User #399198
    'Experience is something you don't get until just after you need it.' -Steven Wright

  3. #3
    cli knowledge at the moment is failing me how would i do that exactly (the server is headless, ssh is the only way to work on it).

  4. $spacer_open
  5. #4
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Nottingham, England
    You need to use a combination of the commands:

    chown (changes ownership and optionally group)
    chgrp (changes file group)
    chmod (changes file permissions)

    Take a look through the man page for each.
    Linux user #126863 - see

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts