Find the answer to your Linux question:
Results 1 to 2 of 2
I can't seem to get it working the way I want it.. I want to share my entire root directory, in workgroup 'Workgroup', accessible only by IPs starting with 192.168, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    unknown
    Guest

    [SOLVED] Help getting Samba share working..


    I can't seem to get it working the way I want it.. I want to share my entire root directory, in workgroup 'Workgroup', accessible only by IPs starting with 192.168, and requiring the 'root' login and password.. what should my smb.conf file look like?

    thanks in advance.

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,893
    Blimey, that seems pretty dangerous. Are you sure you want to do this? Are you sure you can trust _all_ the people that use your lan?

    Anyway:

    - make sure your workgroup is set to 'Workgroup' in smb.conf
    - turn on encrypted passwords in smb.conf
    - make sure you have a user alias for root in /etc/samba/smbusers that looks like this:

    root=administrator

    - set root's samba password with smbpasswd to the same as the 'administrator' on your windows computer.
    - set up a share with '/' as the directory path, read+write access and proper user/group control (read man smb.conf for help with this)
    - restart samba
    - log in as administrator on the windows machine and test your config - you should just be able to log in without entering a password or username in this config. If you're a different user, it should ask for a username and password.
    Linux user #126863 - see http://linuxcounter.net/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •