Find the answer to your Linux question:
Results 1 to 5 of 5
Installed Squid and got everything running on the bares. made a acl rule to allow only internal domains to access the proxy, however a auth type login would come more ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2005
    Posts
    12

    Squid configuration


    Installed Squid and got everything running on the bares. made a acl rule to allow only internal domains to access the proxy, however a auth type login would come more handy (since i don't want -all- of the computers in the domain to access it, and since there are some wildly given ip's, i cannot add a specific rule). How can i accomplish this, if it can be accomplished?

    Also, to avoid double posting, how can i get Squid to run every time my machine boots?

  2. #2
    Just Joined!
    Join Date
    Sep 2005
    Posts
    44
    There are so many sites which provide squid configuration and other things. Search google and go to some sites of squid.

  3. #3
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,846

    Re: Squid configuration

    Quote Originally Posted by BrunoM
    Also, to avoid double posting, how can i get Squid to run every time my machine boots?
    You need to add it to the runlevel you normally boot into. I dont know which distro you are using, but they all come with runlevel or service level editors. The one for Fedora Core is called:

    system-config-services
    Linux user #126863 - see http://linuxcounter.net/

  4. #4
    Just Joined!
    Join Date
    Sep 2005
    Posts
    12

    Re: Squid configuration

    reading the squid docs says that a 3rd "party" program is needed to enable auth-type management. aye, compiled, and got it working. However for soem reason he's not validating the passwords. These are the exact same from the passwd file, so i'm not sure where did i **** up.

    Quote Originally Posted by Roxoff
    Quote Originally Posted by BrunoM
    Also, to avoid double posting, how can i get Squid to run every time my machine boots?
    You need to add it to the runlevel you normally boot into. I dont know which distro you are using, but they all come with runlevel or service level editors. The one for Fedora Core is called:

    system-config-services
    aye, thanks! Am running slackware, figured it out how to do it.

  5. #5
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Belgium
    Posts
    1,429
    Slackware: just put the daemon in the /etc/rc.d directory and add the command to rc.local - but I figure you already discovered that by now .
    ** Registered Linux User # 393717 and proud of it ** Check out www.zenwalk.org
    ** Zenwalk 2.8 - Xfce 4.4 beta 2- 2.6.17.6 kernel = Slack on steroids! **

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •