Find the answer to your Linux question:
Results 1 to 2 of 2
Hi all, I set apache with directory authentication. But whenever I access the folder which provide access authentication, the window which ask for username and password indeed pop-up [seems ready ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2003
    Posts
    34

    DBM User Authentication


    Hi all,

    I set apache with directory authentication. But whenever I access the folder which provide access authentication, the window which ask for username and password indeed pop-up [seems ready to accept authentication] but whenever I login using the accounts which I previously made / allowed
    to access my private directory It just won't make the user pass.

    I invoked the following to see if indeed the users were made and it provides:

    # /usr/sbin/dbmmanage /etc/httpd/dbmpasswd view
    user1:R3b5cytY6RH0o
    ruser2:tLmz9AB0i5Us6

    Also, here's my http.conf entries

    <Directory /var/www/html/private/>
    Options None
    AllowOverride AuthConfig
    AuthName "Restricted Area"
    AuthType Basic
    AuthDBMType GDBM
    AuthDBMUserFile /etc/httpd/dbmpasswd
    require valid-user user1 user2
    </Directory>

    I provided a chmod 640 access permission and chown root.www on the /etc/httpd/dbmpasswd file. But nothing seem to give good news.
    Httpd restart produce no error. HTTP access.log and error.log likewise did not give any errors.

    It seems that the entries "AuthDBMUserFile /etc/httpd/dbmpasswd" was not giving any effect even if I restarted the http service.

    I'm stuck for so many weeks now figuring-out the problem. Hope you expert out there can contribute a solution to my BIG PROBLEM.

    A million 10ks in advance.

  2. #2
    Just Joined!
    Join Date
    Sep 2006
    Posts
    5
    alright I'm having a similar issue with this freakin DBM package. Hopefully we can help each other out and get things working.
    Can you post your ./configure parameters?

    Mine are:
    ./configure --prefix=/usr/local/apache2 --with-mpm=prefork --enable-so --enable-access --enable-auth-dbm --enable-ssl --with-ssl=/usr/local/openssl/ --disable-charset-lite --disable-include --disable-env --disable-setenvif --disable-status --disable-autoindex --disable-asis --disable-cgi --disable-negotiation --disable-imap --disable-actions --disable-userdir --disable-alias


    Try the above in red and see if you have the same problem.
    I'm trying to do access per .htaccess file. I have done this with the plain text files but now I want to use the database.

    my httpd.conf is:

    <Directory /ssl/pictureTalk/userFiles>
    AuthDBMAuthoritative on
    </Directory>

    and then my .htaccess file is:
    AuthType Basic
    AuthName "Private Area!"
    AuthDBMUserFile /usr/local/apache2/conf/thesheff17/thesheff17
    Require valid-user

    I see you have AuthDBMType GDBM are you sure this is the type of database you compiled in? As you can see in my ./configure I didn't pick one. I just want the default but tried all the different types located here:

    http://httpd.apache.org/docs/2.0/mod/mod_auth_dbm.html

    The errors I get in error_log
    $
    [Mon Sep 04 18:36:37 2006] [error] [client 10.1.10.86] (2)No such file or directory: could not open dbm (type default) auth
    file: /usr/local/apache2/conf/thesheff17/thesheff17,<FILE came from>

    The problem is I tried all the different ones inside that apache link?....have you ever had dbm working correctly?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •