Find the answer to your Linux question:
Results 1 to 6 of 6
Distro : OpenSuse 10 command line only. Default Apache installed. (The one that comes with the OS) The Document Root is /srv/www/htdocs/ I have started the daemon with /usr/sbin/rcapache2 start ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2005
    Location
    New Zealand
    Posts
    8

    Apache Server not functioning


    Distro : OpenSuse 10 command line only.
    Default Apache installed. (The one that comes with the OS)

    The Document Root is /srv/www/htdocs/

    I have started the daemon with /usr/sbin/rcapache2 start

    and confirmed it with /usr/sbin/rcapache2 status
    Checking for httpd2: running

    have tried a restart /usr/sbin/rcapache2 restart
    Syntax OK
    Shutting down httpd2 (waiting for all children to terminate) done
    Starting httpd2 (prefork) done

    The firewall is open to http
    The Lan Card is set to an IP address

    in /var/log/apache2 i get
    [Thu Oct 27 23:56:19 2005] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
    [Thu Oct 27 23:56:19 2005] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Thu Oct 27 23:56:19 2005] [notice] Apache/2.0.54 (Linux/SUSE) configured -- resuming normal operations

    Is there something I'm missing, because when I go to connect using a webbrowser via the IP, it doesn't even try to connect?

  2. #2
    Linux Engineer
    Join Date
    Apr 2005
    Location
    Buenos Aires, Argentina
    Posts
    908
    Do a "ps aux | less" to see if it's actually running. Also, note that those are just "warnings" and "notices", not errors. So that means that you should be able to connect.
    serzsite.com.ar
    "All the drugs in this world won\'t save you from yourself"

  3. #3
    Just Joined!
    Join Date
    Oct 2005
    Location
    New Zealand
    Posts
    8
    ps aux resulted in
    root 13062 0.0 0.0 41592 3556 ? Ss Oct27 0:00 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf
    wwwrun 13063 0.0 0.0 41592 3568 ? S Oct27 0:00 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf
    wwwrun 13064 0.0 0.0 41592 3568 ? S Oct27 0:00 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf
    wwwrun 13065 0.0 0.0 41592 3568 ? S Oct27 0:00 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf
    wwwrun 13066 0.0 0.0 41592 3568 ? S Oct27 0:00 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf
    wwwrun 13067 0.0 0.0 41592 3568 ? S Oct27 0:00 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf

    and the SuSEfirewall has
    FW_SERVICES_EXT_TCP="22 http https ssh"

    I've since restarted the server and it's still not going, please save me from reverting back to Windows Server 2k3

  4. #4
    Linux User Stefann's Avatar
    Join Date
    Nov 2004
    Location
    Boise, ID
    Posts
    340
    Quote Originally Posted by facade
    ps aux resulted in
    root 13062 0.0 0.0 41592 3556 ? Ss Oct27 0:00 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf
    wwwrun 13063 0.0 0.0 41592 3568 ? S Oct27 0:00 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf
    wwwrun 13064 0.0 0.0 41592 3568 ? S Oct27 0:00 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf
    wwwrun 13065 0.0 0.0 41592 3568 ? S Oct27 0:00 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf
    wwwrun 13066 0.0 0.0 41592 3568 ? S Oct27 0:00 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf
    wwwrun 13067 0.0 0.0 41592 3568 ? S Oct27 0:00 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf

    and the SuSEfirewall has
    FW_SERVICES_EXT_TCP="22 http https ssh"

    I've since restarted the server and it's still not going, please save me from reverting back to Windows Server 2k3
    Run YaST and configure the firewall from there, preferably from X if you have it(easier for some reason) but you probably don't as this is supposed to be a server machine, correct? Anyways, the idiot test, disable the firewall and try Apache then, if it works the firewall needs to be configured, othewise you have deeper trobules.
    Nothing is worse than ten penguins fighting over which is better, vi or emacs.
    Registered Linux User #404402
    Finally I'm back on LF after a long while.

  5. #5
    Just Joined!
    Join Date
    Aug 2005
    Posts
    5

    re

    Hi from my exp. ( i host a web site for over 2 years) your httpd.conf is mis configured try rereading the apache documention at apache.org .
    in particular pay atention to the install and configure sections

  6. #6
    Just Joined!
    Join Date
    Oct 2005
    Location
    New Zealand
    Posts
    8
    I installed a test server on a small network, got the hang of it and everything ran fine. I will try on the big server/network tommorow.
    Thank you for your help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •