Find the answer to your Linux question:
Results 1 to 2 of 2
hi! i have been having problems with samba and checking out repos using svn. When svn tries to checkout a repo it will give me an error about not being ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2005
    Posts
    9

    samba issues


    hi! i have been having problems with samba and checking out repos using svn. When svn tries to checkout a repo it will give me an error about not being able to move the .svn dirs under the top level of what it is trying to checkout. It will say permission denied when it tries to move them. I am also not able to remove the source dirs. when i build things. I can extract the source for something as user a on a samba share and then build stuff, but when i try to delete the source as user a i get an error that says permission denied. Here is my smb.conf

    Code:
    # Global parameters
    [global]
            workgroup = HOME
            netbios name = SRV
     enable privileges = yes
            #interfaces = 192.168.5.11
            username map = /etc/samba/smbusers
            server string = Samba Server %v
            security = user
            encrypt passwords = Yes
            #min passwd length = 3
            obey pam restrictions = No
            #unix password sync = Yes
            passwd program = /usr/bin/smbldap-passwd -u %u
     #passwd chat = "Changing password for*\nNew password*" %n\n "*Retype new password*" %n\n"
            ldap passwd sync = Yes
            log level = 0
            syslog = 0
            log file = /var/log/samba/log.%m
            max log size = 100000
            time server = Yes
            socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
            mangling method = hash2
            #Dos charset = 850
            #Unix charset = ISO8859-1
            domain logons = Yes
            os level = 65
            preferred master = Yes
            domain master = Yes
            wins support = no
            passdb backend = ldapsam:ldap://127.0.0.1/
            # passdb backend = ldapsam:"ldap://127.0.0.1/ ldap://slave.idealx.com"
     # ldap filter = (&(objectclass=sambaSamAccount)(uid=%u))
            ldap admin dn = cn=samba,ou=DSA,dc=genesis,dc=blogdns,dc=net
            ldap suffix = dc=genesis,dc=blogdns,dc=net
            ldap group suffix = ou=Groups
            ldap user suffix = ou=Users
            ldap machine suffix = ou=Computers
            ldap idmap suffix = ou=Users
            ldap ssl = no
            add user script = /usr/bin/smbldap-useradd -m "%u"
            ldap delete dn = Yes
            delete user script = /usr/bin/smbldap-userdel "%u"
            add machine script = /usr/bin/smbldap-useradd -w "%u"
            add group script = /usr/bin/smbldap-groupadd -p "%g" 
            delete group script = /usr/bin/smbldap-groupdel "%g"
            add user to group script = /usr/bin/smbldap-groupmod -m "%u" "%g"
            delete user from group script = /usr/bin/smbldap-groupmod -x "%u" "%g"
            set primary group script = /usr/bin/smbldap-usermod -g "%g" "%u"
    
    [homes]
            comment = home dirs
            browseable = no
            public = no
            writable = yes
            valid users = seshu prashant 
            mangled names = no
            inherit permissions = yes
    
    [web]
            comment = web
            browseable = no
            public = no
            writable = yes
            valid users = seshu
            path = /home/httpd/html

  2. #2
    Just Joined!
    Join Date
    Sep 2005
    Posts
    9
    after adding exec to my fstab i seem to be able to checkout svn repos from the client now. but i still am not able to build things and then delete the source. i also added create mask = 0777, directory mask = 0777, force create mode = 0777, and force directory mode = 0777 to my smb.conf, but they do not seem to be having any affect. When i do ls -al it still shows -rwxr-xr-x. Any ideas?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •