Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Where on earth do I publish my HTML files using Apache 2.0 on a Suse 10 box?...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Enthusiast
    Join Date
    Dec 2004
    Posts
    637

    Publishing HTML to Apache 2


    Where on earth do I publish my HTML files using Apache 2.0 on a Suse 10 box?

  2. #2
    Linux Enthusiast
    Join Date
    Dec 2004
    Posts
    637

    Getting closer

    Okay, I've deleted the files contained within /srv/www/htdocs and moved my Web site into this directory. Now, when trying to view the site I am getting an access denied error. I didn't change any permissions on the directory so what am I doing wrong? I checked the Apache config and the document root is pointed to /srv/www/htdocs. I have also tried copying the Web site to the www directory as well as creating another directory with the name of my site and made the appropriate changes using YaST. I have experienced an "Access Denied" error using all three methods.

    Any ideas as to what I'm doing wrong? Please help, my frustration is growing beyond my control.

  3. #3
    Linux Newbie
    Join Date
    Jul 2005
    Location
    Turn Around
    Posts
    202
    sounds like its gotta be file permissions. google this and try to fix it then come back if you cant.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast
    Join Date
    Dec 2004
    Posts
    637

    I have

    Google has been my best friend, especially during the SAMBA server rollout. Now, configuring this Apache server is the last piece of the initial Linux rollout. However, I can't seem to get Apache to allow for Web publishing.

    I have my HTML files in the /srv/www/htdocs directory but when trying to access the Apache server via port 80, I'm getting a big fat Access Denied with an error of 403 that points to a read protection or no index file. Now I can assure you of an index.htm file.

  6. #5
    Banned
    Join Date
    Jul 2004
    Posts
    947
    chmod 777 /srv/www/htdocs/foo.html

  7. #6
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    Quote Originally Posted by the_guy_dressed_in_black
    chmod 777 /srv/www/htdocs/foo.html
    That's exactly what I had to do when my site ran apache2, only I had to do it to every single freaking file, for some reason chmodding recursively didn't solve the issue... changed to a different httpd and problem solved, plus lighttpd is much faster...
    Operating System: GNU Emacs

  8. #7
    Banned
    Join Date
    Jul 2004
    Posts
    947
    Quote Originally Posted by genesus
    Quote Originally Posted by the_guy_dressed_in_black
    chmod 777 /srv/www/htdocs/foo.html
    That's exactly what I had to do when my site ran apache2, only I had to do it to every single freaking file, for some reason chmodding recursively didn't solve the issue... changed to a different httpd and problem solved, plus lighttpd is much faster...
    well why not
    Code:
    chmod 777 /srv/www/htdocs/folderName
    chmod 777 /srv/www/htdocs/folderName/*

  9. #8
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    I did, but that changed the permissions on the folder and not the documents within it, plus new documents always had to be changed as well, also this didn't work when I added the recursive option in chmod. Now, it would work if the documents were created in the folder; however, since my /var/www/htdocs is public I prefer to create files in another folder. Apache2 did work, but I didn't like this peculiar disfunctionality, plus its extremely slow compared to the alternative I found...
    Operating System: GNU Emacs

  10. #9
    Banned
    Join Date
    Jul 2004
    Posts
    947
    Quote Originally Posted by genesus
    I did, but that changed the permissions on the folder and not the documents within it, plus new documents always had to be changed as well, also this didn't work when I added the recursive option in chmod. Now, it would work if the documents were created in the folder; however, since my /var/www/htdocs is public I prefer to create files in another folder. Apache2 did work, but I didn't like this peculiar disfunctionality, plus its extremely slow compared to the alternative I found...
    what are you using??
    monkey?

  11. #10
    Linux Enthusiast
    Join Date
    Dec 2004
    Posts
    637

    It's up!

    Well, after a few hours of tinkering, I got it working. For some reason, whenever I deleted the dafault apache files (i.e. index.html.en etc..) from the HTDOCS directory, I would hose the permissions. So, I uninstalled and reinstalled Apache and simply copied my site into the HTDOCS directory. Changed my index.htm index file to index.html and all is working. I just don't like the added junk in my site.

    Anyway, what is the big issue with the way I was trying to set this up. The default index.html.en, .fr, etc. is to show that you have a working install, it shouldn't be crucial to the site, right? How secure is the default install?

    I do have to reconfigure some of my site, since I utilized FP Extension using IIS 6, but since I'm now a convert to Linux, I have to come up with another solution for some of my interactive forms. Are there any FP Extension emulators out there for the LAMP community?

    Oh, by the way, have I told you all how much I love this Linux? Wow, what a learning curve, but with a lot of tinkering, research, and reading it is possible for a Windows Server administrator to make the change. I'm here to stay!

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •