Find the answer to your Linux question:
Results 1 to 4 of 4
hi, ive been trying to install Firestarter on my FC4 since morning. I did a "yum install firestarter" but it couldnt find firestarter, so i decided to download the firestarter ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Nov 2004
    Posts
    167

    Its like Firestarter just crashed my FC4


    hi,

    ive been trying to install Firestarter on my FC4 since morning. I did a "yum install firestarter" but it couldnt find firestarter, so i decided to download the firestarter RPM file from the fs-security website itself.

    Doing the normal rpm -Uvh......i had firestarter installed, but the GUI interface kept resulting in errors msgs about my NICs. I tested te NICs indivudually to make sure that they were working(with one disabled, the other configured with a static IP...and vice-versa) to test for internet connectivity. Each worked independent of the other, and Firestarter reported no errors on the single NICs working alone.. The problem was when both are active, I will get an error msg to test if I have internet connectivity.

    I tried both cards, running the Firestarter wizard, and choosing eth0 for external while eth1 for internal and vice-versa, of-course making necessary ip changes and doing ping tests to and fro. all to no avail. still i get the error "to check for internet connectivity.

    Now ive totally removed firestarter.....and my boot-up has dropped to snail speed. i even had to boot up using interactive mode, cos the thing is just damn too slow now.

    pls, what could be the problem of this slowness.
    Toks

  2. #2
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,628
    Quote Originally Posted by Tokunbo
    pls, what could be the problem of this slowness.
    Toks
    FC4.

    Seriously, I don't know about the slowness, only that I've had a lot of trouble with FC4 in general that I never had with previous versions. On the firewall thing, if Firestarter is not cooperating the way you want, why not try guarddog. I've got it running on my wife's FC4 laptop without any trouble.
    Linux Mint + IceWM Registered:#371367 New Members: click here

  3. #3
    Linux Newbie
    Join Date
    Nov 2004
    Posts
    167
    Yes, u know what, i think Firestarter has a problem with FC4, or vice-versa. I had installed it successfully in a jiffy on RH9, but i decided to upgrade to FC4.

    I have 2NICs, one onboard, and the other, and external NIC.

    I thot to do a fresh install of Fedora, so this morning, i re-installed Fedora. Using eth0, the external NIC, I configured the NIC with the IPs from my ISP and could connect to the web immediately. So i did a "yum install firestarter". Firestarter was installed.

    I ran the GUI config several times to set it up and made the ff observations...weird?

    In my settings/network..... the onboard card is labelled as eth1.

    observation,
    1) with eth1 deactivated, i can connect to the web with eth0, active and configured with static IPs, etc.

    2)with eth0 deactivated, and eth1 activated, I can connect to the web with eth1 configured with my static IPs.

    so, if one NIC is active and the other de-activated, i can connect to the WWW.

    3) if I change the dns settings of eth1, the DNS settings of eth0 change automatically

    4)using firestarter GUI config tool, with eth0 as external and eth1 as internal, i get the error: "failed to start the firewall, pls check that your network
    device settings and make sure your internet connection is active"

    if eth0 is internal and eth1 is external, and necessary changes have been made on IP assignments / firestarter config tool, the same error(4) persists.

    5) When I boot/reboot my PC or do a "service network start/restart" only eth0 gets started. Note: eth0 is the external NIC., so i have to activate eth1 manually everytime.

    pls advise,
    Toks

  4. #4
    Linux Newbie
    Join Date
    Nov 2004
    Posts
    167
    i actually wanted an alternative to DHCP.....I had tried my best to configure dhcp but its always failing.

    toks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •