Seems like I found the solution

When reading an article on setting up a NFS client (http://www.sgmltools.org/HOWTO/NFS-HOWTO/t1109.html), I thought of reducing the rsize and wsize values...

So instead of setting them to 8192, I tried 4096 and it works without a problem

Problem solved !!