Find the answer to your Linux question:
Results 1 to 5 of 5
I have made a complete mess of my MySQL installation under Ubuntu Breezy! Ubuntu 5.10 comes with MySQL 4.1 preinstalled and running and I set up a localhost client/server with ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2006
    Posts
    16

    How to Completely uninstall MySQL to correct a scr*wed install?


    I have made a complete mess of my MySQL installation under Ubuntu Breezy!

    Ubuntu 5.10 comes with MySQL 4.1 preinstalled and running and I set up a localhost client/server with mysql-administrator (new user and privilidges) - connected OK but using mysql-query-browser had a problem (can't connect to socket .... ) and password / host issues.

    My dumb butt removed my user and root accounts, removed MySQL 4.1 and installed 5.0 via RPM's with alien and ran mysql_install_db, but now MySQL thinks that root has a password (I figure it should be null) and it is not anything that I can access from the previous setting, and wont let me set up the client/server. Just removing via synaptic and re-installing makes no difference!

    How can I kill everything, including settings so I can start again?

  2. #2
    Linux Engineer jledhead's Avatar
    Join Date
    Oct 2004
    Location
    North Carolina
    Posts
    1,077
    try sudo dpkg --purge packagename


    then to install I would try this
    http://www.devside.net/web/server/linux/mysql

    easiest damn install I have ever done for mysql

  3. #3
    Just Joined!
    Join Date
    Jan 2006
    Posts
    16
    Thank you That did the trick.

    May the joy of a thousand lifetimes visit your home!

  4. #4
    Just Joined!
    Join Date
    Jan 2009
    Posts
    2

    Unhappy I tried to use installation instruciton you recommended but failed

    Hi,

    I tried to use instrucitons as you recommended at

    MySQL for Linux

    for mysql 5.0.

    Everything went pretty well. I unpacked archive, make directories and managed to start mysqld as instructed. However when I tried to make clean up I received strange message saying

    ./bin/mysql_secure_installation: 230: mysql: not found

    Indeed, it is installed in directory /usr/local/mysql/bin and it is there.
    I tried to call mysql directly. Result was the same. I have no idea of what to do by now. Could you help? Thanks in advance.

    Vladimir Astashkin
    vladimir.astachkine@gmail.com

  5. #5
    Just Joined!
    Join Date
    Jan 2009
    Posts
    2
    [QUOTE=va147147;662771]

    Hi,

    Some more information. I found out that if I try to call mysql as

    ./bin/mysql &

    then it starts. Sorry I am from Windows world coming to Ubuntu recently.
    This is my first installation. I do not completely understand what's going on.

    Thank you,

    Vladimir

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •