Find the answer to your Linux question:
Results 1 to 2 of 2
Have a problem getting cgi script to work... Here is error: The requested URL /cgi-bin/yabb/YaBB.cgi was not found on this server. Shouldn't that be looking at /www.myaddress.net/cgi-bin/yabb/YaBB.cgi ?? I edited ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User
    Join Date
    Nov 2002
    Posts
    420

    Getting cgi to work...


    Have a problem getting cgi script to work...
    Here is error:
    The requested URL /cgi-bin/yabb/YaBB.cgi was not found on this server.
    Shouldn't that be looking at /www.myaddress.net/cgi-bin/yabb/YaBB.cgi ??

    I edited httpd.conf to allow cgi scripts and set the directories correctly, also chmodded what needed to be done...

    DocumentRoot "/var/www"
    Regular web page works ok...

    ScriptAlias /cgi-bin/ "/var/www/cgi-bin/ "
    <Directory "/var/www/cgi-bin/">
    AddHandler cgi-script .cgi
    -rwxrwxrwx 1 knightmare users 13344 Dec 6 12:03 Settings.pl
    -rwxrwxrwx 1 knightmare users 2969 Dec 6 11:54 YaBB.cgi
    See anything wrong?? Who want's to telnet in and fix this one

  2. #2
    Linux Enthusiast scientica's Avatar
    Join Date
    Sep 2003
    Location
    South- or "Mid-" Sweden
    Posts
    742

    Re: Getting cgi to work...

    Quote Originally Posted by KnightMare
    ScriptAlias /cgi-bin/ "/var/www/cgi-bin/ "
    I'm not sure, it probably shouldn't matter, but, do you see the space between the '/' and the '"'? What happens if you remove it?

    btw,. here two exerpts from mine httpd.conf (if that can be of any help):
    Code:
            # ScriptAlias&#58; This controls which directories contain server scripts.
            # ScriptAliases are essentially the same as Aliases, except that
            # documents in the realname directory are treated as applications and
            # run by the server when requested rather than as documents sent to the client.
            # The same rules about trailing "/" apply to ScriptAlias directives as to
            # Alias.
            ScriptAlias /cgi-bin/ "/var/www/cgi-bin/"
    Code:
    <Directory "/var/www/cgi-bin">
            Options ExecCGI
            
            AllowOverride None
            Allow from from all
    
            Order allow,deny
    </Directory>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •