Find the answer to your Linux question:
Results 1 to 3 of 3
Hello All, I'm trying to run Samba and more specificlly Swat. I keep getting an error when I try to access Swat through http://localhost:901 . "The operation timed out when ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! Certified Angus Beef's Avatar
    Join Date
    Feb 2006
    Posts
    4

    Exclamation Samba, Swat Timed Out


    Hello All,

    I'm trying to run Samba and more specificlly Swat. I keep getting an error when I try to access Swat through http://localhost:901. "The operation timed out when attempting to connect www.localhost.com"
    Things I have done or done wrong ... I'm new, you tell me!

    ===============

    Installed Redhat 8.0 (Fresh install, It's all I had)
    Removed Samba RPM's

    ===============

    Downloaded Samba source samba-3.0.21b.tar.tar
    Config, Make, Make install (Life is good)

    ===============

    service smb start (Life id good)

    # find / -name swat -print
    /etc/xinetd.d/swat
    /usr/local/samba/sbin/swat
    /usr/local/samba/swat
    #
    Binary is in /usr/local/samba/sbin/

    ===============

    Verified swat is in services file
    /etc/sevices
    swat 901/tcp (life is good)

    ===============

    Created /etc/xinetd.d/swat (as follows)

    # default: off
    # description: SWAT is the Samba Web Admin Tool. Use swat \
    # to configure your Samba server. To use SWAT, \
    # connect to port 901 with your favorite web browser.
    service swat
    {
    port = 901
    socket_type = stream
    wait = no
    only_from = localhost
    user = root
    server = /usr/local/samba/sbin/swat
    log_on_failure += USERID
    disable = no
    }

    ===============

    Restart services
    killall -HUP xinetd
    (also used Services Configuration interface)
    (life good)

    ===============

    service smb restart (Life id good)

    ===============

    When I try to access Swat in my browser through http://localhost:901. I get; "The operation timed out when attempting to connect ww.localhost.com"

    I know I can do the smb.conf manually (maybe) but this is one more thing I want to be able to do. I'm pretty new to Linux and I just want something to work. Baby steps! I have had some experiance with linux in the past.

    Help! Help! Any help you can afford me would be great.

  2. #2
    Linux User
    Join Date
    Jan 2006
    Posts
    251
    Do you have the line
    127.0.0.1 localhost
    in ur 'hosts' file in /etc(this is one of the reasons)

  3. #3
    Just Joined! Certified Angus Beef's Avatar
    Join Date
    Feb 2006
    Posts
    4
    Quote Originally Posted by nature
    Do you have the line
    127.0.0.1 localhost
    in ur 'hosts' file in /etc(this is one of the reasons)

    Yes that line is there ..... thanks for the responce.
    Anyone ??? Anyone ??

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •