Find the answer to your Linux question:
Results 1 to 10 of 10
Had a recent request to setup an FTP server and I want to utilize my existing Apache Web server, running SuSE 10. I already have VSFTPD installed; however, I'm lacking ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Enthusiast
    Join Date
    Dec 2004
    Posts
    637

    Confiruging VSFTPD on SuSE


    Had a recent request to setup an FTP server and I want to utilize my existing Apache Web server, running SuSE 10. I already have VSFTPD installed; however, I'm lacking information on how to configure.

    I did a search of the forums with no luck as well as Google. Anybody care to point me in the right direction. I tried to start the service by looking within /etc/init.d; however, no luck. YaST only references TFTP as an available network service.

    TIA

  2. #2
    Linux Enthusiast
    Join Date
    Dec 2004
    Posts
    637
    Okay, I'm getting a little closer; however, I cannot get vsftpd to start. The configuration file is in /etc/init.d but it won't start.

    Here is the input at the CLI:

    linux:/ # /etc/init.d/vsftpd start
    bash: /etc/init.d/vsftpd: No such file or directory
    linux:/ # cd /etc/init.d
    linux:/etc/init.d # vsftpd start
    500 OOPS: vsftpd: cannot open config file:start
    linux:/etc/init.d #

    The vsftpd.conf file is properly located under /etc/init.d but vsftpd executable is not found under /etc/init.d - what have I done wrong? Any help will be welcomed. By the way, I'm running SuSE 10.

  3. #3
    Linux Enthusiast
    Join Date
    Dec 2004
    Posts
    637
    Okay, I'm getting a little closer; however, I cannot get vsftpd to start. The configuration file is in /etc/init.d but it won't start.

    Here is the input at the CLI:

    linux:/ # /etc/init.d/vsftpd start
    bash: /etc/init.d/vsftpd: No such file or directory
    linux:/ # cd /etc/init.d
    linux:/etc/init.d # vsftpd start
    500 OOPS: vsftpd: cannot open config file:start
    linux:/etc/init.d #

    The vsftpd.conf file is properly located under /etc/init.d but vsftpd executable is not found under /etc/init.d - what have I done wrong? Any help will be welcomed. By the way, I'm running SuSE 10.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! wraith's Avatar
    Join Date
    Apr 2005
    Location
    Sault Ste. Marie, Canada
    Posts
    54
    2 weeks ago I setup my vsftpd server on my suse 10.0 machine. I had tons of trouble and can't remember what excatly i did to finally get it going..

    check out..
    http://www.novell.com/coolsolutions/feature/14689.html
    http://www.ferdychristant.com/blog/articles/DOMM-6FJMR9

    Also i remember reading something like xinetd and init conflict with eachother listening on the same port or something so vsftpd wont start. I killed xinetd i think and thats when i could finally start vsftpd..

    anyways.. just wanted to help..

  6. #5
    Linux Enthusiast
    Join Date
    Dec 2004
    Posts
    637
    Thanks, I finally gave up making it work on SuSE and installed CentOS on another machine. I installed VMware and am running two Linux distros and Windows server on the same box. One of the instances is running CentOS 4.2 and vsftpd. Works like a charm, but the switch to a RHEL clone was a bit tricky since you have to assume full root for many of the CLI commands. SuSE is a lot easier in some regards; however, high-end server setups are easier on RHEL and the various clones.

    Thanks for the feedback! One thing about Linux is that you never stop learning.

  7. #6
    Linux Enthusiast
    Join Date
    Dec 2004
    Posts
    637

    Just a follow-up

    For those who may be searching for this topic in the future, I did figure out how to get vsftpd to work on SuSE. From the opensuse.org Web site:

    Quick Setup
    Install vsftpd using YaST software management
    Enable vsftpd in xinetd. This can be done manually by editing /etc/xinetd.d/ and changing disabled = yes to disabled = no, or by using the following command
    chkconfig vsftpd on
    Start xinetd if its not running already.
    /etc/init.d/xinetd start
    Make sure that xinetd is started automatically at boot time
    chkconfig xinetd on
    Check that FTP server is working fine. By default only anonymous login is allowed. Data in /srv/ftp/ is made publicly available.
    If neccessary, adapt firewall settings. With SuSEFirewall2 add ftp to FW_SERVICES_EXT_TCP, e. g. (with SSH reachable from the internet, too)
    FW_SERVICES_EXT_TCP="ftp ssh"
    and if you need passive ftp or nat, change also resp.
    FW_LOAD_MODULES="ip_conntrack_ftp ip_nat_ftp"

  8. #7
    Just Joined!
    Join Date
    May 2006
    Posts
    2

    different error

    I was following your post in order to figure out how to make the vsftpd server run and edited the files and yet when I try to start ftp I get the following error;

    CD4SRV5:~ # ftp 10.2.118.46
    Connected to 10.2.118.46.
    500 OOPS: could not bind listening IPv4 socket

    any insight would be greatly appreciated.

    I am running SUSE 10 on a dell 3000 machine for an intranet only app

  9. #8
    Just Joined!
    Join Date
    Dec 2006
    Posts
    1

    VSFTP Problem OpenSuSE 10.2

    Quote Originally Posted by k9fto
    CD4SRV5:~ # ftp 10.2.118.46
    Connected to 10.2.118.46.
    500 OOPS: could not bind listening IPv4 socket
    Exactly the same happens on my server. If i do this:

    rcxinetd stop
    vsftp

    as root, then vsftp is working... Could anyone help to run vsftp with xinetd?
    Thank's. Steve

  10. #9
    Just Joined!
    Join Date
    Feb 2007
    Posts
    1

    Arrow Re:Could anyone help to run vsftp with xinetd?

    Quote Originally Posted by stephanw
    Exactly the same happens on my server. If i do this:

    rcxinetd stop
    vsftp

    as root, then vsftp is working... Could anyone help to run vsftp with xinetd?
    Thank's. Steve
    I had the exact same problem when setting up vsftpd on 10.0[necessary because of old hardware].
    open a terminal window
    su [to become root if not already]
    type the following:
    killall vsftpd

    Go to Yast>Network Services>Network Services(xinetd)>
    Scroll down and you should see "ftp" under the services column
    Select "ftp"
    Click the "Toggle Status (on or off)" to turn it off.
    Click "Finish"

    Go back to your terminal window and type the following:
    /usr/sbin/vsftpd &

  11. #10
    Just Joined!
    Join Date
    Jul 2007
    Posts
    1

    working in suse 10.2

    i likewise had a problem getting vsftp to run in opensuse. i tried everything in the above thread, and running it explcitly did work.. but, of course, it was only configured for anonymous access... reading through the /etc/vsftpd.conf file, i noticed a line Listen=YES

    i disabled that line, killed the vsftpd, marked it an on in inetd.conf, and now it seems to run fine from there...

    hope this helps

    dan

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •