Find the answer to your Linux question:
Results 1 to 6 of 6
Hi i am runnign a SUSE linux distribution, with Samba configured, but i ran into this problem i cant seem to load profiles in win2k or win XP, any clue ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    3

    Help with Samba SUSE


    Hi i am runnign a SUSE linux distribution, with Samba configured, but i ran into this problem i cant seem to load profiles in win2k or win XP, any clue how i can fix this im kinda of new to this still.

  2. #2
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    Luton, England, UK, Earth
    Posts
    639
    Is the problem that you cannot load the profiles through samba on a remote win2k or xp machine, or is it on a host machine?

  3. #3
    Just Joined!
    Join Date
    Dec 2004
    Posts
    15
    You should post your smb.conf so people know where you're coming from.

    So you've already had the clients join the domain? If you're a complete newb, make sure you have the server name selected when you're trying to log in.

  4. #4
    Just Joined!
    Join Date
    May 2005
    Posts
    3
    ok the machines are already connected to the domain, but they cannot retrieve their roaming profile from the server. i will post my smb.conf

  5. #5
    Just Joined!
    Join Date
    Dec 2004
    Posts
    15
    I must say, if you're using SuSE 10, setting up samba as a Primary Domain Controller is pretty easy if you do it from Yast/Network Services/Samba Server.

    From there you can do additional config from the /etc/samba/ directory using any text editor, or you can choose to do it using swat, which ships with Samba.

    To get swat working you have to configure xinetd (I'm still not entirely sure what this is; seems to be similar to activating and deactivating services as seen in Windows 2000/XP) Yast/Network Services/Network Services (xinetd). Enable xinetd, go down to the "swat" service, then click on the "Toggle Status" button to activate the swat service.

    Then you can reach it from http://localhost:901 from a local webbrowser and do even more config from there; check on samba's status, etc. Very useful to figure out what's working and what's not and have a GUI to set up pretty much every option native to Samba.

    I'm not an expert on samba but I have run into my share of problems.

  6. #6
    Just Joined! watchman's Avatar
    Join Date
    Apr 2006
    Location
    Maine, USA
    Posts
    10
    Some simple things to check. (If you have already done these then don't be offended).

    1. Make sure that the user exists in smbpasswd

    smbpasswd -a username

    2. make sure that the home directory exists and is owned by the user

    mkdir /home/username
    chown username /home/username

    3. If the home directory was copied from a windows box, change owner with the recursive option.

    chown -R username /home/username

    I am no samba expert either, but whenever we cannot get profiles here it is because of one of the above.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •