Find the answer to your Linux question:
Results 1 to 2 of 2
Hi there, I am new to exim so please excuse if it is a silly question. I am not new to Linux or Network Administration in general. I need a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Location
    Germany
    Posts
    69

    exim - Could not complete sender verify callout


    Hi there,
    I am new to exim so please excuse if it is a silly question. I am not new to Linux or Network Administration in general.
    I need a fast solution because I have a server where users can't receive their e-mails. Any help is really really appreciate.

    The server (FC4 + cpanel) runs exim 4.52
    The configuration is standard, no special things. It wasn't configured by me, but now I am in charge..
    There are a lot of mails in exim_reject rejected with: Could not complete sender verify callout
    2006-03-26 04:11:54 H=(mail.xxx.com) [x.x.156.26] F=<xxxx@tips.xx.xx.xx> temporarily rejected RCPT <yyy@xxx.com>: Could not complete sender verify callout
    There are also authentic domains (ex: mail.citigroup.com ) for which emails are rejected.
    I've read something about exim verifications and I understood how the whole thing (callout verification) works: the server tries a smtp connection with the sender server and if something goes wrong the message is rejected. This is mainly because of wrong configured servers and MX records. It I am wrong please correct me.

    What I want to do, is to configure the server to exclude some domains which are not spam-senders.
    How can I accomplish that?
    I've read about sender_verify, sender_verify_hosts *, sender_verify_hosts_callback *, sender_verify_callback_domains ! *.some.domain :* but I don't know where in exim.conf to set them. When I restart exim after I add these option I get an error:
    Starting exim-smtps: 2006-03-27 22:50:56 Exim configuration error in line 29 of /etc/exim.conf:
    main option "sender_verify_callback_domains" unknown
    Please tell me how can I exclude some domains from this verification, and where in exim.conf to add the new options.

    Thanks for your help

  2. #2
    Just Joined!
    Join Date
    Jan 2005
    Location
    Germany
    Posts
    69
    HI,
    I created an acl. Something like:
    #added just for testing on 28-03-2006
    test_acl:
    accept hosts = mail.xxx.com
    Then before the line: require verify = sender/callout (the only line which refers to callout verifying), I added:
    condition = ${if !match {$sender_address_domain}{+test_acl}}
    There is no configuration error, but also nothing has changed.

    From the logs I get:


    2006-03-28 12:44:24 H=(mail.xxx.com) [xx.xx.156.26] F=<dxrxha@txxxl.com> temporarily rejected RCPT <xxx@stxxx.com>: Could not complete sender verify callout
    What have I done wrong? What to do next?
    I will read and learn about exim, about principles and what happens under the hood, but in the moment I need a fast solution so that my clients can get their mails.

    Thanks a lot.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •