Find the answer to your Linux question:
Results 1 to 9 of 9
Can anyone give me the solution for the below mention problem . It would be very greatful . [root@localhost root]# telnet localhost 25 Trying 127.0.0.1... Connected to localhost. Escape character ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2004
    Location
    kathmandu
    Posts
    5

    qmail problem


    Can anyone give me the solution for the below mention problem . It would be very greatful .

    [root@localhost root]# telnet localhost 25
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    220 himalmedia.com ESMTP
    user ujjwal
    502 unimplemented (#5.5.1)
    pass ujjwalrana
    502 unimplemented (#5.5.1)
    quit
    221 himalmedia.com
    Connection closed by foreign host.

  2. #2
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    hi, i got round to installing qmail on my comp tonight, that message is supposed to happen exactly as you posted it. You are not meant to log into the smtp daemon.

    to check how much of it is working run
    Code:
    qmailctl stat
    it should look like this
    Code:
    /service/qmail-send: up (pid 1667) 2877 seconds
    /service/qmail-send/log: up (pid 1668) 2877 seconds
    /service/qmail-smtpd: up (pid 1669) 2877 seconds
    /service/qmail-smtpd/log: up (pid 1670) 2877 seconds
    messages in queue: 0
    messages in queue but not yet preprocessed: 0
    if it says command not found or is incomplete then go to
    http://www.lifewithqmail.org/lwq.html
    and read thru section 2 (installing qmail), if u follow it exactly then it will work (it did for me anyway).

  3. #3
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    ujjwal, I don't really see what you're trying to do. SMTP has never had a USER or PASS command.

  4. #4
    Just Joined!
    Join Date
    Jan 2004
    Location
    kathmandu
    Posts
    5

    regarding qmail again

    My mail is in queue now so any suggestion what shall i do for those mail which is in queue :-

    kindly have a look on look on below mention things :-

    [root@localhost control]# qmailctl stat
    /service/qmail-send: up (pid 201 2513 seconds
    /service/qmail-send/log: up (pid 2019) 2513 seconds
    /service/qmail-smtpd: up (pid 2022) 2513 seconds
    /service/qmail-smtpd/log: up (pid 2023) 2513 seconds
    messages in queue: 2
    messages in queue but not yet preprocessed: 0
    /service/qmail-pop3d: up (pid 2033) 2513 seconds
    /service/qmail-pop3d/log: up (pid 2034) 2513 seconds

  5. #5
    Just Joined!
    Join Date
    Jan 2004
    Location
    kathmandu
    Posts
    5

    qmail problem

    Quote Originally Posted by Dolda2000
    ujjwal, I don't really see what you're trying to do. SMTP has never had a USER or PASS command.
    My mail is in queue now so any suggestion what shall i do for those mail which is in queue :-

    kindly have a look on look on below mention things :-

    [root@localhost control]# qmailctl stat
    /service/qmail-send: up (pid 201 2513 seconds
    /service/qmail-send/log: up (pid 2019) 2513 seconds
    /service/qmail-smtpd: up (pid 2022) 2513 seconds
    /service/qmail-smtpd/log: up (pid 2023) 2513 seconds
    messages in queue: 2
    messages in queue but not yet preprocessed: 0
    /service/qmail-pop3d: up (pid 2033) 2513 seconds
    /service/qmail-pop3d/log: up (pid 2034) 2513 seconds

  6. #6
    Just Joined!
    Join Date
    Jan 2004
    Location
    kathmandu
    Posts
    5

    qmail problem

    Quote Originally Posted by Hellmasker
    hi, i got round to installing qmail on my comp tonight, that message is supposed to happen exactly as you posted it. You are not meant to log into the smtp daemon.

    to check how much of it is working run
    Code:
    qmailctl stat
    it should look like this
    Code:
    /service/qmail-send: up (pid 1667) 2877 seconds
    /service/qmail-send/log: up (pid 1668) 2877 seconds
    /service/qmail-smtpd: up (pid 1669) 2877 seconds
    /service/qmail-smtpd/log: up (pid 1670) 2877 seconds
    messages in queue: 0
    messages in queue but not yet preprocessed: 0
    if it says command not found or is incomplete then go to
    http://www.lifewithqmail.org/lwq.html
    and read thru section 2 (installing qmail), if u follow it exactly then it will work (it did for me anyway).
    Hi ; thanks a lot for your wonderful help . In short i have no words to describe how much you have help . Anway lets talk about the problem .
    My mail is in queue now . So any suggestion what shall i do for those mail or messages which is in queue :-

    kindly have a look on look on below mention things :-

    [root@localhost control]# qmailctl stat
    /service/qmail-send: up (pid 201 2513 seconds
    /service/qmail-send/log: up (pid 2019) 2513 seconds
    /service/qmail-smtpd: up (pid 2022) 2513 seconds
    /service/qmail-smtpd/log: up (pid 2023) 2513 seconds
    messages in queue: 2
    messages in queue but not yet preprocessed: 0
    /service/qmail-pop3d: up (pid 2033) 2513 seconds
    /service/qmail-pop3d/log: up (pid 2034) 2513 seconds

  7. #7
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    I haven't used qmail, so I don't know for sure, but when message remain in the queue, it's usually because there is a problem with delivering them. Surely, qmail must a log file or some other means to find out what has gone wrong with them.
    Again, I haven't used qmail, so I don't know exactly where to look. If you can't find it, I suggest you wait until someone with qmail experience replies.

  8. #8
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    it shoudl have sent a failure notification to the psotmaster or mailer-daemon address.

    depending on how u set up your mailboxes, (i will assume u set root, postmaster, etc etc to yourself), you shoudl have received a email saying roughly

    "mail to: whoever
    from: whoever

    has failed bcause or .... reason here....

    the original messag was....."

    for me it sends this to /home/hellmasker/Mailbox, although u may have left ti as wherever the default is, u wil have to fidn this yourself from help files or whateve rcoz i dont know.

    worth a try tho:
    less /home/username/Mailbox
    or
    less /home/username/Maildir/current

  9. #9
    Just Joined!
    Join Date
    Jan 2004
    Location
    kathmandu
    Posts
    5

    qmail problem

    Quote Originally Posted by Hellmasker
    it shoudl have sent a failure notification to the psotmaster or mailer-daemon address.

    depending on how u set up your mailboxes, (i will assume u set root, postmaster, etc etc to yourself), you shoudl have received a email saying roughly

    "mail to: whoever
    from: whoever

    has failed bcause or .... reason here....

    the original messag was....."

    for me it sends this to /home/hellmasker/Mailbox, although u may have left ti as wherever the default is, u wil have to fidn this yourself from help files or whateve rcoz i dont know.

    worth a try tho:
    less /home/username/Mailbox
    or
    less /home/username/Maildir/current


    As per your suggestion i did check the path and It seems that your and mine is almost the same . Even my username is in the same path as like your one . Kindly have a look on below mention things :-

    [root@localhost ujjwal]# less /home/ujjwal/Maildir


    total 20
    drwx------ 5 ujjwal ujjwal 4096 Jan 12 18:23 ./
    drwx------ 3 507 507 4096 Jan 12 18:24 ../
    drwx------ 2 ujjwal ujjwal 4096 Jan 12 18:23 cur/
    drwx------ 2 ujjwal ujjwal 4096 Jan 12 18:23 new/
    drwx------ 2 ujjwal ujjwal 4096 Jan 12 18:23 tmp/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •