Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Am I the only one who finds Samba hard? Anyway... Forgive my other posts, but I am going to make this the final one to see if I can get ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2006
    Posts
    24

    Samba Shares - browse and play mp3, but can't write


    Am I the only one who finds Samba hard? Anyway...

    Forgive my other posts, but I am going to make this the final one to see if I can get this working.

    Fedora Core 4
    Samba Version 3.0.14a-2

    Samba is running. The firewall is completely off. I have created user "sjoiner" and added him to group "tech". I have added sjoiner to smbpasswd with the same password as the unix user.

    I created a directory called /test_part. I chmodded it using "chmod -R 0777 /test_part". This directory is on the first had drive mounted as "/", which is mounted in 'fstab" like such:

    LABEL=/1 / ext3 defaults 1 1

    I then copied about 5 directories with mp3's in them to the "test_part" directory.

    Here is my smb.conf file:
    ----------------------------------
    # Global Parameters

    [global]
    workgroup = jhome1
    netbios name = closet1
    encrypt passwords = Yes
    security = user

    [homes]
    read only = no
    browseable = no
    create mask = 0664
    directory mask = 0775

    [test_part]
    browseable = yes
    valid users = @tech, sjoiner
    writeable = yes
    public = yes
    path = /test_part
    force create mode = 0770
    force directory mode = 0770
    --------------------------------------------

    I am trying to access these shares from a Windows XP machine, logged on as sjoiner with the correct password.

    I am able to type \\closet1 and see the server. When I double-click on it, it opens and shows me two shares: "sjoiner" and "test_part".

    When I try to open the "sjoiner" share, which i assume is my home share, it quickly gives me a permission error saying that the path was not accessible and that it does not exist.

    Moving on. When I double-click on the "test_part" share it let's me browse it and play the mp3's. However, under no circumstances can I write new files to the directory. It tells me I do not have permission. I'm stuck once again.

    I will say that dealing with SAMBA is very difficult. I've followed at lest 3 different "HOWTOS" painstakingly, and none of them have worked for me.

    I appreciate any help figuring this out.

  2. #2
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Please confine your questions to one thread when they are all relating to the same problem. Posting individual related questions on several threads makes it a real headache for anyone trying to help you.
    Registered Linux user #270181
    TechieMoe's Tech Rants

  3. #3
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    stevenjo57,
    1. add a path field for home e.g.
    [homes]
    read only = no
    browseable = no
    create mask = 0664
    directory mask = 0775
    path = /home/%U

    2. for the mp3 share try chmod -R 766 /test_part
    Life is complex, it has a real part and an imaginary part.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2006
    Posts
    24

    Thanks, but a "no-go"

    Thank you for your help.

    I made the changes. I added the "path = /home/%u" to the [homes] section but still get the access record saying the path does not exist.

    I did a chmod for the /shares/test_part directory with a -R to 766 and was unable to even view the directory.

    Since you helped me last, I've set up several more shares. They all work fine except for my inability for ANY authorized user to write to them. Any attempt is immediately met with an error that says "Cannot copy. Access is denied. Make sure the disk is not full or write-protected and that the file is not currently in use."

    Here is my latest smb.conf, pretty much the same, except several more shares.

    Everything works correctly except writing to the shares. The access codes for users are working - we can all read and view and execute video and mp3. But none of us can write to any of the shares.

    Thanks again. This is all very puzzling.
    -------------------------
    # Global Parameters

    [global]
    workgroup = jhome
    netbios name = closet
    encrypt passwords = Yes
    security = user
    username map = /etc/samba/smbusers

    [homes]
    read only = no
    browseable = no
    create mask = 0664
    directory mask = 0775
    path = /home/%U

    [music]
    comment = MP3 Music
    browseable = yes
    valid users = @users
    write list = @users
    writeable = yes
    path = /shares/music
    force create mode = 0777
    force directory mode = 0777


    [pictures]
    comment = Family Pictures
    browseable = yes
    valid users = @users
    write list = @users
    writeable = yes
    path = /shares/pictures
    force create mode = 0777
    force directory mode = 0777

    [stevedocs]
    comment = Steve's Documents
    browseable = yes
    valid users = steve, sjoiner
    write list = steve, sjoiner
    writeable = yes
    path = /shares/stevedocs
    force create mode = 0777
    force directory mode = 0777

    [dianedocs]
    comment = Diane's Documents
    browseable = yes
    valid users = steve, sjoiner, diane
    write list = steve, sjoiner, diane
    writeable = yes
    path = /shares/dianedocs
    force create mode = 0777
    force directory mode = 0777

    [nathandocs]
    comment = Nathan's Documents
    browseable = yes
    valid users = steve, sjoiner, nathan
    write list = steve, sjoiner, nathan
    writeable = yes
    path = /shares/nathandocs
    force create mode = 0777
    force directory mode = 0777

    [stephaniedocs]
    comment = Stephanie's Documents
    browseable = yes
    valid users = steve, sjoiner, stephanie
    write list = steve, sjoiner, stephanie
    writeable = yes
    path = /shares/stephaniedocs
    force create mode = 0777
    force directory mode = 0777

    [melissadocs]
    comment = Melissa's Documents
    browseable = yes
    valid users = steve, sjoiner, melissa
    write list = steve, sjoiner, melissa
    writeable = yes
    path = /shares/melissadocs
    force create mode = 0777
    force directory mode = 0777
    --------------------------------

  6. #5
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    hmm, only thing I can think of is this:
    get rid of the force create and directory modes fields in smb.conf and just chmod -R 766 directory_name
    Life is complex, it has a real part and an imaginary part.

  7. #6
    Just Joined!
    Join Date
    Apr 2006
    Posts
    24

    Thanks

    OK.

    Removed the force create and directory parameters, chmoded the /shares/music -R 0766. Restarted samba.

    Was unable to access /shares/music at all. Denied access. Nothing about the path this time, but you may not have the right to access this directory.

    Seems like EVERY effort is blocking a network attempt to write to any of these directories. I must have a setting elsewhere that is buggering it. Could it be FSTAB, could it be the ownership of the directories?

    Here is my FSTAB:
    --------------------------------
    # This file is edited by fstab-sync - see 'man fstab-sync' for details
    LABEL=/1 / ext3 defaults 1 1
    /dev/devpts /dev/pts devpts gid=5,mode=620 0 0
    /dev/shm /dev/shm tmpfs defaults 0 0
    /dev/proc /proc proc defaults 0 0
    /dev/sys /sys sysfs defaults 0 0
    LABEL=SWAP-hda2 swap swap defaults 0 0
    /dev/hdc /media/cdrecorder auto pamconsole,exec,noauto,managed 0 0
    --------------------------------------
    Here is my latest smb.conf. Again, everything but writing to any of the directories seems to be OK. Oh, yes, I can't even browse the home directories, but that doesn't bother me at this point. THANKS FOR YOUR HELP!
    --------------------------
    # Global Parameters

    [global]
    workgroup = jhome
    netbios name = closet
    encrypt passwords = Yes
    security = user
    username map = /etc/samba/smbusers

    [homes]
    read only = no
    browseable = no
    create mask = 0664
    directory mask = 0775
    path = /home/%U

    [music]
    comment = MP3 Music
    browseable = yes
    valid users = @users
    write list = @users
    writeable = yes
    path = /shares/music
    force create mode = 0777
    force directory mode = 0777


    [pictures]
    comment = Family Pictures
    browseable = yes
    valid users = @users
    write list = @users
    writeable = yes
    path = /shares/pictures
    force create mode = 0777
    force directory mode = 0777

    [stevedocs]
    comment = Steve's Documents
    browseable = yes
    valid users = steve, sjoiner
    write list = steve, sjoiner
    writeable = yes
    path = /shares/stevedocs
    force create mode = 0777
    force directory mode = 0777

    [dianedocs]
    comment = Diane's Documents
    browseable = yes
    valid users = steve, sjoiner, diane
    write list = steve, sjoiner, diane
    writeable = yes
    path = /shares/dianedocs
    force create mode = 0777
    force directory mode = 0777

    [nathandocs]
    comment = Nathan's Documents
    browseable = yes
    valid users = steve, sjoiner, nathan
    write list = steve, sjoiner, nathan
    writeable = yes
    path = /shares/nathandocs
    force create mode = 0777
    force directory mode = 0777

    [stephaniedocs]
    comment = Stephanie's Documents
    browseable = yes
    valid users = steve, sjoiner, stephanie
    write list = steve, sjoiner, stephanie
    writeable = yes
    path = /shares/stephaniedocs
    force create mode = 0777
    force directory mode = 0777

    [melissadocs]
    comment = Melissa's Documents
    browseable = yes
    valid users = steve, sjoiner, melissa
    write list = steve, sjoiner, melissa
    writeable = yes
    path = /shares/melissadocs
    force create mode = 0777
    force directory mode = 0777

    [utilities]
    comment = Utilities
    browseable = yes
    valid users = steve, sjoiner, melissa, nathan, diane, stephanie
    write list = steve, sjoiner, melissa, nathan, diane, stephanie
    writeable = yes
    path = /shares/utilities
    force create mode = 0777
    force directory mode = 0777
    --------------------------------------------

  8. #7
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    your fstab and everything look fine, I noticed you are using Fedora Core, have you tried turning off the firewall or SELinux?

    note: I haven't used Fedora before, so I don't know how to turn them off, but I have heard that SELinux is enabled by default.
    Life is complex, it has a real part and an imaginary part.

  9. #8
    Just Joined!
    Join Date
    Apr 2006
    Posts
    24

    Smile

    Finally resolved.

    It may have been the SELinux TAB, whatever that is. in the Security Level system settings, it seemed like the SELinux tab was activated.

    Anyway, all seems OK now.

    Thanks to everyone for help. My fileserver is kicking b*** now!

  10. #9
    Just Joined!
    Join Date
    Apr 2006
    Posts
    1

    thank you!

    This SELinux fix solved a problem that I'd been hassling with for two days! Now my fileserver is fully functional!

  11. #10
    Just Joined! tom-tjtech's Avatar
    Join Date
    Apr 2006
    Location
    Scotland
    Posts
    51

    Arrow Samba shares - browse and play mp3, but can't write

    Check..
    Are your samba users also linux users?

    check the they are listed end of '/etc/passwd' file.

    The samba users need local system authority to logon to linux -just a guess.
    ####
    as admin (su then login as root)

    run
    [root]$ testparm

    (any errors) this tests you smb.conf file for syntax and structure errors?

    Im not sure about 'writeable = yes' I thaught it was 'readonly = no' but I may be wrong on this!

    ####
    Do you use SWAT to manage and create your shares?
    In the browser type..
    http://jhome:901/

    and restart all services using the STATUS page.

    Try these out..

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •