Find the answer to your Linux question:
Results 1 to 6 of 6
Hello all. Ive finally got my server running, but when I went to test out my configuration on another computer at my house (using the same internet connection), nothing came ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! Byroman's Avatar
    Join Date
    Mar 2006
    Location
    St. George, Ontairo, Canada
    Posts
    38

    Cant acess website from antoher computer...


    Hello all. Ive finally got my server running, but when I went to test out my configuration on another computer at my house (using the same internet connection), nothing came up. Usually i get a Page Not Found error or a Server Not Found error. When i go onto my server, and try to acess my website, it works perfectly. At my school one after noon I tried it as well, and it worked great again. So my problem is that I cant acess my website from another computer using the same internet connection as my server. Is this normal, or is there a way that I can do this? Any help is greatly apreciated.
    Thanks,
    Byroman

  2. #2
    Linux Engineer jledhead's Avatar
    Join Date
    Oct 2004
    Location
    North Carolina
    Posts
    1,077
    are you using internet dns names(www.blahblah.com) or local ip's, like 192.168.1.. ?

  3. #3
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    well, on some routers you will not be able to see the site from another computer on the router if you enter your domain name, that is why the above poster suggested using your local ip of the server, eg 192.168.0.3, or whatever your router has assigned to the server.
    Operating System: GNU Emacs

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! Byroman's Avatar
    Join Date
    Mar 2006
    Location
    St. George, Ontairo, Canada
    Posts
    38
    Hello,
    Thanks for the reply. I have tried both, the domian name (http://byroman.homelinux.org) and the ip adress of the server, but neither on them work on any of my other computers. If there some sort of function that I should enable on my router to allow this?
    Thanks,
    Byroman

  6. #5
    Linux Engineer jledhead's Avatar
    Join Date
    Oct 2004
    Location
    North Carolina
    Posts
    1,077
    using the local ip (10.... 192..... 172.....) should work unless the ip apache is set to listen on is set to your WAN ip address. you should try
    Listen *:80

    so that apache listens on any ip that comes its way on port 80.

    but make sure you are using private ips in the first step above

  7. #6
    Just Joined! Byroman's Avatar
    Join Date
    Mar 2006
    Location
    St. George, Ontairo, Canada
    Posts
    38
    Humm... ok. This is all very wierd. I jst tried acessing it again from another computer (using the private IP) and now its working. I guess i did somthing right
    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •