Find the answer to your Linux question:
Results 1 to 3 of 3
Hi, I'm new to the linux game, but having a great time so far. I have a new dedicated server that I connect to remotely through SSH from my host, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2006
    Posts
    1

    Unable to connect to Apache


    Hi, I'm new to the linux game, but having a great time so far.

    I have a new dedicated server that I connect to remotely through SSH from my host, its running FC4. After doing a "Perfect Setup" and installing ISPConfig, I am currently unable to connect to my server via http or https. I've even tried ftp (i have proftpd installed via the "Perfect Setup" instructions) and I cant connect (not even asking for a login).

    I've searched and think I've narrowed it down to possibly a firewall problem.

    The output of my iptables -L is :

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination
    RH-Firewall-1-INPUT all -- anywhere anywhere

    Chain INPUT (policy ACCEPT)
    target prot opt source destination
    RH-Firewall-1-INPUT all -- anywhere anywhere

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    Chain RH-Firewall-1-INPUT (2 references)
    target prot opt source destination
    ACCEPT all -- anywhere anywhere
    ACCEPT icmp -- anywhere anywhere icmp any
    ACCEPT ipv6-crypt-- anywhere anywhere
    ACCEPT ipv6-auth-- anywhere anywhere
    ACCEPT udp -- anywhere 224.0.0.251 udp dpt:5353
    ACCEPT udp -- anywhere anywhere udp dpt:ipp
    ACCEPT all -- anywhere anywhere state RELATED,ESTABLISHED
    ACCEPT tcp -- anywhere anywhere state NEW tcp dpt:ssh
    REJECT all -- anywhere anywhere reject-with icmp-host-prohibited
    I havent messed with my iptables before so I wanted to check before I started screwing around. Do I need to open port 80? And if so, what commands should I use to do it? Or am I completely off base?

  2. #2
    Linux Enthusiast
    Join Date
    Dec 2004
    Posts
    637
    What distro and by the way, if you are running a RHEL clone are you by chance running SE Linux? If so, this may be a problem. Have you tried disabling the firewall to narrow the problem down to a root cause?

  3. #3
    Just Joined!
    Join Date
    Nov 2006
    Posts
    6
    I think that your problem is in ISPConfig, as it asks you for your RSA pass phrase eachtime it restarts, so if u chose to encrypt your RSA Key during the setup, each time you restart the server for any reason or restart ISPConfig, you will have to enter the pass phrase in order to run http (Apache); actually i am having the same problem, and trying to find a solution that doesnt include reinstalling ISPConfig

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •