Find the answer to your Linux question:
Results 1 to 10 of 10
Hi, i recently installed and configured a Samba server on a RedHat 6.0 machine. I am trying to access the machine from a Windows XP machine connected to the same ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2006
    Location
    St Albans
    Posts
    17

    Connecting to Samba Server from WinXP Machine


    Hi, i recently installed and configured a Samba server on a RedHat 6.0 machine. I am trying to access the machine from a Windows XP machine connected to the same router (so same physical network). The i.p. of the XP machine is 192.168.0.30 and i have set the i.p. of the Samba machine to 192.168.0.60.
    I can ping the samba server in cmd.exe and can also find it using the Find-->Computer tool. However, i am unable to connect/explore the samba server from XP. I have set up an account on the Samba machine with the same user name and password as the client machine (XP) but to no avail. Can someone help me in figuring out how to enable me to explore the samba machine from XP. thanks
    Richard.

  2. #2
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    What errors do you get? Have you set up proper share directories?

    Could you post the contents of your smb.conf please?

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  3. #3
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Maybe a hint or two here:
    http://ubuntuguide.org/#sambaserver
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    May 2006
    Location
    St Albans
    Posts
    17

    Samba - continued

    i followed the guide @ http://ubuntuguide.org/#sambaserver for setting up a new user with their own password and sharing files for read write access but i still get the error,

    '\\192.168.0.60 is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find if you have access permissions.

    The Account is not authorised to log in from this station.'


    I am really stuck as to what to do. Cheers
    Richard.

    p.s. my samba config sile is exactly the same as outlined after the changes in the http://ubuntuguide.org/#sambaserver guide.

  6. #5
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    As Bryan pointed out, did you make sure your file permissions on the server are set right?
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  7. #6
    Just Joined!
    Join Date
    May 2006
    Location
    St Albans
    Posts
    17

    Samba contd.pt.2

    OK so essentially all i want to do is be able to access the /root directory on the linux machine (i.p. 192.168.0.60) from either of the two other machines on the same physical network (192.168.0.52 and 192.168.0.30).
    i will only need one account which can read/write/do whatever the hell i want with the files

    n.b. are there any other options i can change to make the file sharing system more efficient?

    Below is a typed copy of each value from the smb.conf file

    workgroup = MYGROUP
    server string = Samba Server
    hosts allow = 192.168.1 192.168.2
    princap name = /etc/printcap
    load printers = yes
    printing = bad
    guest account = pcguest
    log file = /var/log/samba/log.%m
    max log size = 50
    security = user
    username map = /etc/smbusers
    password server = <NT-Server-Name>
    password level = 8
    username level = 8
    encrypt passwords = yes
    smb passwd file = /etc/smbpasswd
    unix password sync = Yes
    passwd program = /usr/bin/passwd %u
    passwd chat = (cant be assed to write this out)
    username map = /etc/smbusers
    include = /etc/smb.conf.%m
    socket options = TCP_NODELAY
    interfaces = 192.168.12.2/24 192.168.13/24
    remote announce = 192.168.1.255 192.168.2.44
    local master = no
    os level = 33
    domain master = yes
    preferrred master = yes
    domain controller = <NT-Domain Controller-SMBName>
    domain logons = yes
    logon script = %m.bat
    logon script = %U.bad
    logon path = \\%L\Profiles\%U
    name resolve order = wins lmhosts bcast
    wins support = yes
    wins server = w.x.y.z
    wins proxy = yes
    dns proxy = no
    preserve case = no
    short preserve case = no
    default case = lower
    case sensitive = no

    ------------Share Definitions------------
    [homes]
    comment = Home Directories
    browseable = yes
    writable = yes

    [netlogin[
    comment = Network Logon Service
    path = /home/netlogon
    guest ok = yes
    writable = no
    share modes = no

    [profiles]
    path = /home/profiles
    browseable = no
    guest ok = yes

    [printers]
    comment = All printers
    path = /var/spool/samba
    browseable = no

    guest ok = no
    writable = no
    printabe = yes

    [tmp]
    comment = Temporary File Space
    path = /tmp
    read only = no
    public = yes


    Ok i think that is all the information that is important


    Can you tell me how to configure my smb.conf file for this to work.
    Cheers
    Richard.

  8. #7
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Quote Originally Posted by goliathdave
    OK so essentially all i want to do is be able to access the /root directory on the linux machine (i.p. 192.168.0.60) from either of the two other machines on the same physical network (192.168.0.52 and 192.168.0.30).
    I think using SSH would be more appropriate for that.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  9. #8
    Just Joined!
    Join Date
    May 2006
    Location
    St Albans
    Posts
    17

    ...

    ok but the linux box will be moving to a new location with a bigger network and running more services so i would like to get some hands on experience configuring it properly to run in this little set up. anyone out there can help?
    cheers
    richard.

  10. #9
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Ok then. But still you should learn SSH, with which you can even mount remote filesystem with far less configuration needed than with Samba. For example:
    http://ubuntu.wordpress.com/2005/10/...m-using-sshfs/


    Did you do a test on your server just to see if your actual /etc/samba/smb.conf file is in working condition? (You need to do that.)
    Code:
    testparm
    as root.


    Here is a little example of a working /etc/samba/smb.conf file with login enabled. (You need UNIX accounts on the server, plus Samba accounts.)

    Code:
    # Global parameters
    [global]
            workgroup = MYGROUP
            server string = %h server (Samba %v)
            obey pam restrictions = Yes
            passdb backend = tdbsam, guest
            passwd program = /usr/bin/passwd %u
            passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .
            username map = /etc/samba/smbusers
            syslog = 0
            log file = /var/log/samba/log.%m
            max log size = 1000
            dns proxy = No
            panic action = /usr/share/samba/panic-action %d
            invalid users = root
    
    [homes]
            comment = Home Directories
            create mask = 0700
            directory mask = 0700
            browseable = No
    
    [junior]
            comment = some stuff
            path = /home/junior
            force user = nobody
            force group = nogroup
            read only = No
            create mask = 0777
            directory mask = 0777
            guest ok = Yes
    
    [bertha]
            comment = some other stuff
            path = /home/bertha
            force user = nobody
            force group = nogroup
            read only = No
            create mask = 0777
            directory mask = 0777
            guest ok = Yes
    
    [printers]
            comment = All Printers
            path = /tmp
            create mask = 0700
            printable = Yes
            browseable = No
    
    [print$]
            comment = Printer Drivers
            path = /var/lib/samba/printers
    Also with this you need to set the permissions on the server to:
    Code:
    chmod -R 777 /home/bertha
    chown -R nobody:nogroup /home/bertha
    And the same for each directory you want to share.

    Plus you need a /etc/samba/smbusers that denominates the users having rights to mount the shares.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  11. #10
    Just Joined!
    Join Date
    May 2006
    Location
    St Albans
    Posts
    17

    ...

    Thats great the SSH stuff looks like its from Linux to Linux machine which isnt exactly what i wanted to do but still might come in handy. I'm trying to access a linux machine from XP not the other way round.
    The samba stuff does look a little more tricky to configure, anyway, thanks for the help that will definately come in handy when im setting stuff up. I basically just need some sort of app running so that machines on a network can access/talk freely with the server and i'm thinking samba is the best program to do this.

    Thanks
    Richard.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •