Find the answer to your Linux question:
Results 1 to 5 of 5
I have done some reseach and found some remedies but they have not worked for me. I am new to both linux and apache...and webservers. Everything seems to be working ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2006
    Posts
    3

    php file size limit


    I have done some reseach and found some remedies but they have not worked for me. I am new to both linux and apache...and webservers.

    Everything seems to be working fine with my debian apache setup with regard to php except that it imposes a filesesize limit for uploads of 2ish megs. I found the php.ini file ( /etc/php/apache/php.ini ) and tried several different settings for upload_max_filesize but when i view my phpinfo() it always reads '2M' regardless of how i set it. It is currently set to '20M' . I have been restarting apache between changes, and tried rebooting as well.

    Additionally in php.ini i increased max_execution_time, memory_limit, and something else based on advice from my research.

    I tried copying the php.ini file to the folder of the website i am serving.

    I have also tried setting 'LimitRequestBody 0' in httpd.conf with no effect.

    I am at a bit of a loss and would appreciate some help. Its especially frustrating as I am certain the problem is something very simple....

  2. #2
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    you could look into the ini_set() function. And maybe also the [url="http://uk.php.net/manual/en/function.ini-get.php[/url] to confirm that the php scripts are recognising the changes. If it's just one script that you need the upload sizes changing, this would be a better way than to allow larger uploads globally. It's certainly more secure.

    Hope this helps, if not, i will continue to look for you.
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  3. #3
    Just Joined!
    Join Date
    Jun 2006
    Posts
    3
    Using ini_set i was unable to alter upload_max_filesize.

    I added this at the start of my page:
    $whatwasit=ini_set( "upload_max_filesize","8M");
    $whatisit=ini_get( "upload_max_filesize");
    And echoed the result of ini_get which resulted in "2M". So it seems this is somehow locked?

    stephen

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! ElectricEffect's Avatar
    Join Date
    Oct 2007
    Posts
    11
    You're remembering to restart Apache, right?

  6. #5
    Linux Newbie
    Join Date
    Jan 2008
    Location
    UK
    Posts
    211
    This is a bug in PHP that is fixed in version 5.0.4-9
    For more info see link: https://bugzilla.redhat.com/show_bug.cgi?id=155916

    There is also this link about editing the php.ini file:
    How to edit php.ini file to increase memory limit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •