Find the answer to your Linux question:
Results 1 to 9 of 9
Apparently I'm running on a proprietary version of redhat 7.2 and I'm trying to get Apache 2.2, PHP5 and Postgres8 up and running and talking with each other. I've downloaded, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2006
    Posts
    5

    Upgrading Apache from 1.3.33 to 2.2


    Apparently I'm running on a proprietary version of redhat 7.2 and I'm trying to get Apache 2.2, PHP5 and Postgres8 up and running and talking with each other.

    I've downloaded, compiled and installed the various tarballs, but it appears Apache 1.3.33 does not want to pass things on to 2.2. Somehow, somewhere it's still running and when I try to active 2.2 I get the following message:
    (9Address already in use: make_sock: could not bind to address 0.0.0.0:80
    no listening sockets available, shutting down
    Unable to open logs


    Any help would be appreciated.

  2. #2
    Just Joined!
    Join Date
    May 2006
    Posts
    31
    Code:
    apachectl stop
    will stop the current server.
    Or
    Code:
    killall httpd
    if above fails.

  3. #3
    Just Joined!
    Join Date
    Jun 2006
    Posts
    5
    All right, on the server everything is coming up as version 2.2...

    Now the problem is the website won't display, all I get is:

    It works!


    I'm guessing a configuration file needs to be reconfigured... Anyone able to point me in the right direction?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    May 2006
    Posts
    31
    That message is in the index.html file, you need to find the directory where Apache serves web pages from and put your site content there. On Slackware, it /var/www/htdocs.

    httpd.conf is the configuration file. But you did say you compiled from source, so if you just went with the defaults, everything is probably in /usr/local/apache (I think that's the default install path).

    There's alot of crud in the httpd.conf. It's not as complicated as it initially looks. Read the docs for sure.

  6. #5
    Just Joined!
    Join Date
    Jun 2006
    Posts
    5
    With the setup on the server I'm working on, I have to keep the files where they are at. (There's quite a few custom programs that manage things and they need to be where they are...)

    Any idea what file, and what command tells apache where to serve the files from?

  7. #6
    Just Joined!
    Join Date
    Jun 2006
    Posts
    5
    Well I've found the file, it is of course, httpd.conf
    and I've found the command: DocumentRoot

    The problem is, if I change it to where it's suppose to point: /www/domainname
    I get an error when loading the page stating I do not have access to /

    From what I can tell on Google, I'm suppose to create an alias in the current directory: /usr/local/apache2/htdocs
    that will point to where I need it: /www/domainname

    I haven't had much luck with the alias command so far... Any suggestions?

  8. #7
    Just Joined!
    Join Date
    May 2006
    Posts
    31
    Quote Originally Posted by Mythguided
    Well I've found the file, it is of course, httpd.conf
    and I've found the command: DocumentRoot

    The problem is, if I change it to where it's suppose to point: /www/domainname
    I get an error when loading the page stating I do not have access to /

    From what I can tell on Google, I'm suppose to create an alias in the current directory: /usr/local/apache2/htdocs
    that will point to where I need it: /www/domainname

    I haven't had much luck with the alias command so far... Any suggestions?
    If /www/domainname is the main site content then change DocumentRoot as you have:

    Code:
    DocumentRoot "/www/domainname"
    Now a little further down in httpd.conf you should see this:

    Code:
    <Directory />
        Options FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
    </Directory>
    Do not change this! It's important for security.

    Okay, after that section you should see a section like this:

    Code:
    #
    # Note that from this point forward you must specifically allow
    # particular features to be enabled - so if something's not working as
    # you might expect, make sure that you have specifically enabled it
    # below.
    #
    
    #
    # This should be changed to whatever you set DocumentRoot to.
    #
    <Directory "/usr/local/apache2/htdocs">
    The bolded line is what you need to do, change the old DocumentRoot path to your new path. Restart the server.

    Hope this gets you going.

  9. #8
    Just Joined!
    Join Date
    Jun 2006
    Posts
    5
    That did it! Thanks!

    Server is now up and running...

    I'm pretty happy, just breaking in to Linux and with your help made it through. Upgraded Apached, PHP and Postgres and even got PHP to link with PostGres.

    *Happy Dance*

    And thank you again.

  10. #9
    Just Joined!
    Join Date
    May 2006
    Posts
    31
    Cool! Glad I was able to help out.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •