Find the answer to your Linux question:
Results 1 to 3 of 3
hi, I've configured ldap.But when I want to add an entry: ldapadd -x -D "cn=Manager,dc=enspy,dc=edu" -W -f Desktop/example.ldif I get the following error after i entered the password: ldap_bind: Invalid ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2006
    Posts
    6

    open ldap error


    hi,
    I've configured ldap.But when I want to add an entry:

    ldapadd -x -D "cn=Manager,dc=enspy,dc=edu" -W -f Desktop/example.ldif

    I get the following error after i entered the password:

    ldap_bind: Invalid credentials (49)

    What is the problem, and how can I resolve it?

    Thanks.

  2. #2
    Just Joined!
    Join Date
    Jun 2006
    Posts
    7
    Hi,

    Try the following steps.

    1) Run the command "slappasswd"

    Set your new password here. An encrypted string will be displayed.

    For example,

    [root@server1 tmp]# slappasswd
    New password:
    Re-enter new password:
    {SSHA}v4qLq/qy01w9my60LLX9BvfNUrRhOjQZ
    [root@server1 tmp]#


    2) Copy the string and paste it into /etc/openldap/slapd.conf (OpenLDAP main configuration file)

    For example,

    database ldbm
    suffix "dc=enspy,dc=edu"
    rootdn "cn=Manager,dc=enspy,dc=edu"
    rootpw {SSHA}v4qLq/qy01w9my60LLX9BvfNUrRhOjQZ
    directory /var/lib/ldap/enspy.edu


    3) Restart the LDAP service as like below.

    # /etc/init.d/slapd restart

    4) Now, add an LDAP user by using the following command.

    ldapadd -x -a -D "cn=Manager,dc=enspy,dc=edu" -W -f Desktop/example.ldif

    (enter the password which you've specified at the slappasswd command)

    That's it.

    Cheers,

    Rajesh Kannan

  3. #3
    Just Joined!
    Join Date
    Jun 2006
    Posts
    6

    always a problem

    Hi,
    Thanks for your reply rajeshkannan,but it still doesn't work.I have the same error : ldap_bind: Invalid credentials (49). Is there another issue ?
    Thanks.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •