I've searched high and low, but I simply can't find a solution to this...

I have a mandrakelinux 10.2 server running apache 2 and php 4.3, and I can't seem to upload files from outside our network that are over around 1MB in size. From inside the network, I can upload files as large as I want.

I get no error message--just a generic "Connection To Server Has Been Reset" message after about 2 minutes of waiting. I've stripped the html form down to the bare minimum. Tried upping the memory and timeout limits in php.ini, and tried setting the LimitRequestBody directive in apache. I've also turned off the server's software firewall.

I tried putting the same script onto a windows apache/php/mysql installation inside our network, and I was able to upload to that from outside our network without a problem. So, I think that would eliminate the possibility of it being a problem with our routers and point the finger back at a server configuration problem?

Anyone have any ideas?? I'm at a total loss!