Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
I am trying to get the named daemon up and running but having no luck. I have made sure that the keys in the named.conf and rndc.conf are the same ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2004
    Posts
    14

    rndc: connect failed: connection refused


    I am trying to get the named daemon up and running but having no luck. I have made sure that the keys in the named.conf and rndc.conf are the same but its still not having any of it and returns connection refused when trying to start the daemon.

    rndc: connect failed: connection refused

  2. #2
    Linux Enthusiast scientica's Avatar
    Join Date
    Sep 2003
    Location
    South- or "Mid-" Sweden
    Posts
    742
    ok, sounds like an misconfigured BIND config, can you run (as root):
    Code:
    service named restart
    #and then open /var/log/messges, eg via emacs or gvim
    At the bottom, you should see some lines starting with "(date+time) (hostname) named[number]"
    what does it say, any errors?
    Regards Scienitca (registered user #335819 - http://counter.li.org )
    --
    A master is nothing more than a student who knows something of which he can teach to other students.

  3. #3
    Just Joined!
    Join Date
    Feb 2004
    Location
    Reunion island
    Posts
    5
    Make sure that your bind daemon is listening to the right interface in your files :

    - named.conf :
    controls {
    inet 127.0.0.1 port 953
    allow { 127.0.0.1; } keys { "rndc-key"; };
    };


    -rndc.conf :
    options {
    default-key "rndc-key";
    default-server 127.0.0.1;
    default-port 953;
    };


    If it still doesn't work, maybe you could re-create your key with rndc-confgen.

    Hope that will work !

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Feb 2004
    Posts
    14
    Looks like a permissions error on the named.log in /var/log. In that case, what user does services start named under because the log has write permissions as root and im starting the daemon as root?

  6. #5
    Just Joined!
    Join Date
    Feb 2004
    Posts
    14
    appoligies, me being silly. Noticed the -u named option being added in the named startup script. Now thats sorted its still not starting although there are no intuitive errors in the message log.

    Feb 16 09:30:07 mustang named: named shutdown failed
    Feb 16 09:30:07 mustang named[24752]: starting BIND 9.2.1 -u named
    Feb 16 09:30:07 mustang named[24752]: using 1 CPU
    Feb 16 09:30:07 mustang named[24755]: loading configuration from '/etc/named.conf'
    Feb 16 09:30:07 mustang named[24755]: no IPv6 interfaces found
    Feb 16 09:30:07 mustang named[24755]: listening on IPv4 interface lo, 127.0.0.1#53
    Feb 16 09:30:07 mustang named[24755]: listening on IPv4 interface eth0, 80.6.44.237#53
    Feb 16 09:30:07 mustang named[24755]: listening on IPv4 interface eth1, 10.115.74.1#53
    Feb 16 09:30:07 mustang named[24755]: command channel listening on 127.0.0.1#953
    Feb 16 09:30:07 mustang named: named startup failed
    Any ideas why its not starting now?

  7. #6
    Just Joined!
    Join Date
    Feb 2004
    Posts
    14
    sorry, im being stupid again. Just checked the named.log now its able to write to it. Found out theres a perms problem with the named.pid file. Hopefully should be sorted soon.

  8. #7
    Just Joined!
    Join Date
    Feb 2004
    Posts
    14
    ok now very confooosed. Its removing the named.pid file when i modify perms (which i kinda expected cos i thought it created a new file each time a process is created), but its unable to crate a new one. Its also failing to remove the lock file from /var/lock/subsys for some reason. Not sure why because that entry is in the script which i am running as root Any ideas?

  9. #8
    Just Joined!
    Join Date
    Feb 2004
    Posts
    14
    managed to gt it up and running at last. I just cheated and repointed the pid file to /var/run/named/named.pid instead of the default of /var/run/named.pid. Changed the perms on the named directory in /var/run so that user 'named' has write access. Working a treat now! Thanks for ya help.

  10. #9
    Linux Enthusiast scientica's Avatar
    Join Date
    Sep 2003
    Location
    South- or "Mid-" Sweden
    Posts
    742
    I use a chrooted BIND, and I set all the files to be owned by named (both user and group), I had some oermission problems with (among others) the pid file before, but once I changed ownership from root to named it was solved (note you're still able to change the files as r00t, even if both user and group is named).
    Regards Scienitca (registered user #335819 - http://counter.li.org )
    --
    A master is nothing more than a student who knows something of which he can teach to other students.

  11. #10
    Just Joined!
    Join Date
    Feb 2004
    Posts
    14
    I did try chmodding the pid file but it just got removed once it had permission to write to it. I fixed it in the end by using the named subdirectory within subsys.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •