Find the answer to your Linux question:
Results 1 to 3 of 3
Hi, I just set up my webserver yesterday at UNI. Everything worked fine except... When I tried logging in to the ftp, it asked for a username and password, even ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2004
    Posts
    30

    possible problem with tcp wrappers + vsftpd


    Hi, I just set up my webserver yesterday at UNI. Everything worked fine except...

    When I tried logging in to the ftp, it asked for a username and password, even though it was configured for anonymous and when I tried logging in anon it wouldnt let me (through IE).

    It worked fine when logging in to the ftp on the actual machine (j23res4.anu.edu.au) anonymously.

    Im using TCP Wrappers with vsftpd to only allow login to the ftp from the domain anu.edu.au. In hosts.allow I put

    "vsftpd : .anu.edu.au"

    and in hosts.deny I put

    "vsftpd : ALL".

    I though I may have got these wrong and it was preventing it from allowing logins so I changed them to

    "vsftp : .anu.edu.au"

    and

    "vsftp : ALL"

    respectively.

    This did allow me to login into the ftp no worries but I'm not sure if this rule is having any affect.

    Everything was working fine on campus i.e. from the domain anu.edu.au, I could access my webpage, the ftp and jabber server. But when I try to access my website from another place (ie not from the domain anu.edu.au), I dont even get a response from my webserver, no respond to a ping or anything.

    Is it possible that the rule I entered as above is stopping people off-campus from viewing my entire webpage/ftp? Shouldnt it respond to a ping at least?

    This could be the problem or it could be that the ANU (Australia National University) has blocked outside access for my webserver...(it was previously open but perhaps they noticed there was no activity on that IP for a period of six weeks and decided to close it)

    Any ideas?

    Thanks heaps.

  2. #2
    Linux Engineer kriss's Avatar
    Join Date
    Jun 2003
    Posts
    1,113
    My guess would be a firewall of some sort, since even ping is blocked and you said you could connect from within the network, but not outside? And since you don't get ping replies.

    Why don't you ask the network admin or someone in charge?

    Good luck

  3. #3
    Just Joined!
    Join Date
    Feb 2004
    Posts
    30
    Hrm, I set the firewall settings (in the gnome GUI) to highest security and allowed http ftp ssh etc. I've been told that ANU allows ssh from anywhere, be it on campus or off, but I still can't get in that way.

    I think it must be either the maximum security firewall setting in redhat or my hosts.allow file...

    I'm quite sure its supposed to be "vsftpd" not just "vsftp". Maybe this error is causing only anu.edu.au domains to be allowed to connect?

    Update: I think I may know the problem. Apparently at the end of the hosts.allow and hosts.deny files you must have a carrier return on the bottom line or something, i.e. a line but with no text in it. If this isnt there, the last rule may not be activated. Maybe I did had this in the hosts.deny file but not in the hosts.allow file, this could explain why I was not being let in. I then changed the settings to "vsftp : .anu.edu.au" and "vsftp : ALL" in allow and deny respictively. The correct daemon name is vsftpd not vsftp...and I'm hoping this is the problem, does anyone think it could be? Im going back up there tomorrow to sort it out so I'll reply when I found what the problem was.

    Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •