Find the answer to your Linux question:
Results 1 to 4 of 4
Hello, I'm running Apache on a Debian sarge distribution, and I'm trying to get htaccess to work properly. I've followed instructions according to several tutorials, this being one of them: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    2

    problem with setting up .htaccess/.htpasswd


    Hello,

    I'm running Apache on a Debian sarge distribution, and I'm trying to get htaccess to work properly.
    I've followed instructions according to several tutorials, this being one of them:

    http://www.cyberciti.biz/faqs/2006/0...irectories.php

    I've made changes in my httpd.conf accordingly, and indeed, the secure notice pops up.... however, it won't accept the password I've put into .htpasswd. It seems like it simply isn't finding the .htpasswd file, but I verified the location. Changing the location does not have any effect either.

    Is there some other setting somewhere else I have to set as well? I can't see where I forgot anything, but it still isn't working.

  2. #2
    Linux User yourname3232's Avatar
    Join Date
    Aug 2005
    Location
    Pacific Northwest, USA
    Posts
    262
    Is the password in plain text? You can use the generator here ( http://www.kxs.net/support/htaccess_pw.html ) if you need to generate passwords.
    Registered GNU/Linux User #399198
    'Experience is something you don't get until just after you need it.' -Steven Wright

  3. #3
    Just Joined!
    Join Date
    Jul 2006
    Posts
    2
    I tried several types of encryption, as well as plain text passwords, but that didn't help either.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast
    Join Date
    Dec 2004
    Posts
    637
    It sounds like a permissions issue on the .htpasswd file. Where did you place this file and did you check the permissions on this file granting the appropriate read access? I would place this file within the /etc/apache2 directory so that the Apache daemon has appropriate permissions. Just a suggestion.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •