Find the answer to your Linux question:
Results 1 to 6 of 6
Hello everyone . Well here's my problem from the start: Well i'm a complete new linux user, managed to pick up a few things such as installing a few programs ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    11

    Apache Server Access from LAN computer


    Hello everyone .

    Well here's my problem from the start:

    Well i'm a complete new linux user, managed to pick up a few things such as installing a few programs like super karamba and a telent client.

    I managed to install apache 2 ok and connect to it from the linux box - localhost and 127.0.01. However how on earth would you connect to it from another computer on the LAN?

    My network setup:
    Wireless router is the gateway with the linux box connected to it via an ethernet cable (a yellow one ). The computer trying to connect to it is a windows computer which is using a wireless card to connect to the router. The linux box is running suse 10.1

    -----------------------------------------------

    What have I got to put into the browser on the windows machine to get the apache 2 start page?

    Thanks for any help

    Rich.

  2. #2
    Just Joined!
    Join Date
    May 2003
    Location
    MD
    Posts
    12
    open up your web browser on your windows pc and type in the ip address of your server. http://192.168.X.X

    You may need to check your firewall settings in YaST to make sure it'll allow incoming web traffic over port 80.

  3. #3
    Just Joined!
    Join Date
    Jul 2006
    Posts
    11
    I just turned the firewall of for a second and it worked. But which setting is it i have to change? i can't find any logical bit to allow for connections on port 80.

    Thanks msound

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    May 2003
    Location
    MD
    Posts
    12
    Well I'm glad we determined it was your firewall. Unfortuntely I haven't used SuSE for over a year. Maybe you could search the SuSE section for how to open specific ports on the firewall, or better yet, the steps taken to get a working SuSE web server. Good Luck!

  6. #5
    Linux Enthusiast
    Join Date
    Dec 2004
    Posts
    637
    In YaST, go to Security and Users and click on Firewall. Under allowed services, add HTTP server.

  7. #6
    Just Joined!
    Join Date
    Jul 2006
    Posts
    11
    Thanks, I tried that yesterday but I didn't see the next button at the bottom, once the http service had been alowed it worked fantastic.

    Thanks guys!

    I gather if i want to make the site avaliable on the web I just have to forward my router on port 80 to the i.p address of the server.

    Thanks again, what! no reputation points on this forum!

    Rich

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •