Find the answer to your Linux question:
Results 1 to 2 of 2
I have setup a new server with Linux Enterprise and Samba 3.09137. I am missing a step some where. I am not able to join the domain with any machine(all ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2006
    Posts
    2

    Unhappy Joining Domain Problems, first time


    I have setup a new server with Linux Enterprise and Samba 3.09137.

    I am missing a step some where.
    I am not able to join the domain with any machine(all machines are XP that were on the previous samba server)
    When attempting to join domain from Windows System properties I get the following,
    I put the Domain name in and get a login prompt and get this error with root user
    "the name could not be found"
    With the user name Administrator I get "access is denied"
    I have tried a variety of commands and switches with smbpaswd but I am obviously doing something wrong.
    Both users Root and Adimistrators are users in Linux and samba and should have admin rights.

    My Smb.conf is as follows
    # Global parameters
    [global]
    log file = /var/log/samba/%m.log
    passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*success fully*
    obey pam restrictions = Yes
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    domain master = True
    encrypt passwords = yes
    passwd program = /usr/bin/passwd %u
    wins support = true
    dns proxy = No
    netbios name = bms-pdc
    printing = lprng
    server string = Samba Server
    logon script = logon.bat
    unix password sync = yes
    workgroup = bms
    os level = 33
    add user script = /usr/sbin/useradd -d /dev/null -g 100 -s /bin/false -M %u
    domain admin group = @root, @teachers, @admin
    max log size = 0os level = 33
    log level = 2
    pam password change = Yes
    domain logons = Yes

    [homes]
    oplocks = no
    locking = no
    writeable = yes
    comment = Home Directories
    valid users = @teachers,@root,@students
    create mode = 0755
    directory mode = 0775

    [netlogon]
    comment = Network Logon Service
    path = /var/lib/samba/drivers
    guest ok = Yes
    share modes = No

    [profiles]
    csc policy = disable
    writeable = yes
    path = /usr/local/samba/profiles
    write list = bret2,@root
    valid users = bret2,@user,@@users,@Administrator,@administrator, @admin
    create mode = 0600
    public = yes
    directory mode = 0700

    [printers]
    comment = All Printers
    path = /var/spool/samba
    printable = Yes
    browseable = Yes

    [public]
    comment = Public Stuff
    path = /public/apps
    valid users = @teachers @students
    write list = @teachers @students
    read only = No
    guest ok = Yes
    writeable = Yes
    create mode = 777
    directory mode = 777
    Veto oplock files = /*.ARD/*.ARI/*.FPT/*.FMD/*.FMI/*.DAT/*.PCD/*.PCI/*.SRD/*.SRI/*.FPT/

    [optra]
    printer = BMS_OPTRA_LAB
    printable = yes


    [mediactr]
    printer = bms-media
    printable = yes

  2. #2
    Just Joined!
    Join Date
    Aug 2006
    Posts
    2

    Fixed it

    The problem was the Linux firewall was blocking me from joining the domain.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •